24

Recently Notepad++ seems to be very slow when dealing with files that are located on a network share.

I am editing small files (e.g. web.config) and it is slow to:

  • Initially open a file on a network share.
  • Switch tabs back to a file on a network share.
  • Switch back to notepad++ after using another application.

My guess is when switching tabs back to a network file it tries to check if someone else has modified the file (I could live with turning this off and it could check on save).

I am on a "fast" local network and have only noticed this problem recently.

My local PC is Windows 7 Enterprise and the servers are Windows Server 2003 and 2008.

  • Was this ever figured out? I still have this issue and it is maddening since most of my work is done on files remotely – Will P. Apr 27 '15 at 16:33
  • Using the solution provided by @Lex worked perfectly for me. Kinda upsetting though cause I do like that feature. – Rob Nov 9 '16 at 16:23
22

I ran into this exact issue. After asking around and doing some experimentation it seems to be related to Notepad++'s "File Status Auto-Detection" routines. I noticed that the more files from network shares that I had open the slower the UI would be to respond when receiving focus. I resolved this by disabling "File Status Auto-Detection". Perhaps not an optimal solution for all environments. Now I just wish there were a one button or keyboard shortcut option to check to see if the file has been changed since it was opened.

  • 5
    I have actually had this option disabled for a while now and it still exhibits the problem. – row1 Apr 26 '12 at 4:19
  • 7
    The third entry down in the File menu is "Reload from Disk". Under Settings > Shortcut Mapper, you can bind that command to a keyboard shortcut. I set mine to Ctrl - R so it duplicates the Refresh functionality I'm used to in web browsers. – Bobwise Nov 16 '12 at 22:07
  • Settings \ Preferences, then the MISC tab and uncheck Enable under File Status Auto-detection. – Mangs Apr 18 '18 at 15:53
  • I have also had "File Status Auto-Detection" disabled for a while, and it doesn't help much at all. – Jesse Busman Apr 26 '18 at 14:38

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.