I'm running VMWare Worstation 7 with Windows 7 x64 as guest, Windows XP x64 as host. Inside the guest I run a long-running console application, which prints out progress messages with timestamps on them. Sometimes I leave it running for several hours while I lock the host OS and don't touch the computer at all. When I come back I find that some time after I left it seems to have paused and automatically resumed: the console app hasn't made much progress and there's a large time gap in its progress messages.

There's nothing relevant in the host event log, but in the guest Application event log I can see these messages around the time I left:

A request to disable the Desktop Window Manager was made by process (VMware Tools Service)

The Desktop Window Manager was unable to start because composition was disabled by a running application

And later, around the time I returned, this shows up in the System log:

The system time has changed to ‎2012‎-‎01‎-‎12T06:36:46.921000000Z from ‎2012‎-‎01‎-‎12T03:18:19.953079000Z.

That seems to support my theory that it's VMware doing something and not Windows itself. The question is: how do I stop it doing that? I want my application to continue running. By the way, the power options are set to never sleep in both guest and host.

  • How does the fact that the guest didn't run for awhile suggest that VMware's doing something rather than Windows itself? – David Schwartz Jan 12 '12 at 7:45
  • The log message mentioning VMware Tools Service is what suggests it. – EMP Jan 12 '12 at 8:36
  • Could power settings have something to do with it? Check the power savings settings on the host and guest. Especially check whether the host or guest is going to sleep after some idle time because of power settings. – prunge Jan 20 '12 at 1:01
  • Checked - they're both set to never sleep. – EMP Jan 20 '12 at 11:39

Disabling the vmware service will stop it, because you are disabling the communication between the guest and the host. The sleep signal sent from the OS (which is where it originates) is translated through vmware tools, to a pause command. Stopping the service will also compromise all the features of vmware tools like freeing up the memory and other important aspects of running the vm in vmware and performance of the host will suffer.

To solve your problem, go to power settings in windows (right click desktop > personalise > screen saver > power management) and change when your computer goes to sleep. that is all is happening, the default settings for windows 7 is to sleep after 30 mins. This is being sent to the host via vmware tools, which is why disabling the service worked. but that is a real bodge, just change it to 'never' sleep/always on.

| improve this answer | |
  • To add to this answer: you must check your power saving options on both your host and your guest OS. I just had to change my guest OS's sleep options to never sleep, hopefully it will work. – RAKK Feb 11 '15 at 10:02

In VMWARE tools go under the scripts tab, and you will see a script event that probably says 'Suspend Guest operating system'. Untoggle 'Use Script', and that should stop the VM from suspending on its own. I had the same issue and your suggestion about vmware tools tipped me off where to look.

| improve this answer | |
  • Hmm, is that just a guess or have you actually tested this out? I'd be surprised if that made a difference, because that script is run when the VM suspends, it shouldn't cause it to suspend - and all it does is release the IP address anyway. – EMP Jun 9 '12 at 6:37

Disabling the VMWare Tools service appears to have done the trick for me.

Even better, the screen resolution in the guest OS no longer changes when I resize the VMWare window, which was another huge annoyance. So far I'm not missing any functionality, so I'm not really sure what that service is for.

| improve this answer | |
  • 1
    Features such as copy, paste and sharing folders between host and guest – Ivan Castellanos May 22 '14 at 0:28

Disable the Intel Virtualization Technology (or Intel VT-x) option on your BIOS or UEFI.

| improve this answer | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.