I have a brand new Western Digital MyPassport Studio, which I'd like to use as a utility drive. It will boot my Mac Pro over USB, but not over FireWire 800. Western Digital's support basically told me it's not their problem, although their knowledge base article states that the drive should boot an Intel Mac over FireWire.

It's partitioned like so (using GUID):

  • Partition A: 12 GB, HFS+ Journaled
  • Partition B: 63 GB, FAT
  • Partition C: 925 GB, HFS+ Journaled (the remainder, rounded)

I installed Lion on Partition A, so it's now 11.5 GB, after the Recovery HD partition took its share. I've tried booting holding down Option, and neither Partition A or Recovery HD show up, though both do with USB.

Also, when it's plugged in with FW800, Partition A does show up in the Startup preference pane. When I select it and restart, though, it spends a long time before the Apple logo shows up, and I end up booted to my default, internal disk.

I tried plugging directly into the front FW800 port, and also through other (LaCie) drives daisy chained to a rear port, and that made no difference.

This is very frustrating, and would potentially make me return the drive if I can't find a solution. What could be causing this?

  • Check - support.apple.com/kb/HT2699 - do you have built-in FireWire ports? – ChrisF Jan 12 '12 at 13:34
  • Do Western Digital say it should boot off Firewire and it is just your set up? – Mark Jan 12 '12 at 13:52
  • @ChrisF it's a Mac Pro – Dov Jan 12 '12 at 13:58
  • @Mark According to a WD support article, the drive should be bootable on an Intel Mac through FireWire: wdc.custhelp.com/app/answers/detail/a_id/1787/~/… – Dov Jan 12 '12 at 14:02
  • I would format run dusk utility and verify it over firewire or even reformat it over firewire – Mark Jan 12 '12 at 14:07

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.