7

How do I get my sound working again? It works with Headphones, but when I unplug the headphones a red light is coming out of the headphone jack and I can't adjust the volume on my Macbook Pro.

13

macRumors ref: No sound out of MacBook speakers & red LED in Headphone jack.
The red light is probably because its a Mini-TOSLINK port.

There is a metal prong in the jack and sometimes it can be bent,
causing the digital audio to be turned on when it shouldn't be.

.

The problem is there is a switch in the jack that tells it if you have a mini headphone plug or an optical plug plugged into the headphone port. The problem is when you remove the plug, the jack doesn't know it and keeps shining the red light to talk with the optical. This disables the internal speakers and you see digital out instead of internal speakers in the speaker conrtol panel. Plugging and unplugging the speakers may get it working right for awhile but it won't last forever.

And, for the brave hearted,

I slid a paperclip in, and pushed out a little metal on the side.
That did the job, and I have internal sound again. And the digital red light, is now off.


Important Update:
If this answer helped you, please do not add a 'thank you' as another answer...
This is not a forum -- please read the faq.

4
  • I don't see any metal sticking out in there to bend back....
    – ScArcher2
    Sep 8 '09 at 21:04
  • 4
    s/paper clip/toothpick/ - I had this same problem and a wooden toothpick worked great.
    – jtimberman
    Sep 9 '09 at 6:23
  • 2
    I took it to the Apple store. They blew it out with a can of air and it fixed my problem!
    – ScArcher2
    Sep 10 '09 at 17:09
  • Thanks @ScArcher, the toothpick (from other forums) didn't work, but the compressed air did. MUCH thanks. Nov 4 '10 at 1:40
0

Closing the lid and reopening it resolves this for me whenever it occurs, this isn't optimal, but it's quick and easy. When this happened to my macbook 13" unibody (aluminum) model it was very frustrating as I would plug in headphones and they'd seem broken.

The same thing works if your tap-to-click feature stops working, or in that case you can use the system prefs to disable and reenable it.

Not the answer you're looking for? Browse other questions tagged or ask your own question.