I'm doing my best to fix a friends computer, which is failing to boot into Windows (loads the windows boot screen, messes about for a bit, then restarts the process), with the W7 install CD it fails to initialize the repair tools (although seems to be completely okay with installing a new Windows) and Ubuntu loads from a live CD but when I try and access the disk (called Acer), it presents the following:

Error mounting: mount exited with exit code 13: ntfs_attr_pread_i: ntfs_pread failed: Input/output error Failed to read NTFS $Bitmap: Input/output error NTFS is either inconsistent, or there is a hardware fault, or it's a SoftRAID/FakeRAID hardware. In the first case run chkdsk /f on Windows then reboot into Windows twice. The usage of the /f parameter is very important! If the device is a SoftRAID/FakeRAID then first activate it and mount a different device under the /dev/mapper/ directory, (e.g. /dev/mapper/nvidia_eahaabcc1). Please see the 'dmraid' documentation for more details.

(I'm not sure if I should know more before trying to access a Windows HDD from Ubuntu but have had no issues in the past, can't quite tell what the problem is.)

Any ideas?


  • I would pull the hard drive out and put it back in to make sure the connection is good. Sometimes the screw holding it in firmly will be missing and the drive comes loose during handling. Did you try the F8 options to see if it boots in safe mode or last known good configuration? – dwolters Jan 13 '12 at 22:26

I guess it's either a hardware problem (like bad blocks on the HDD) or a partition corrupted in a fairly interesting way that it cause the recovery tools to fail.

Run a disk diagnose tool to be sure. Then find someway to run chkdsk X: /f to fix the file system. One way is to use SHIFT+F10 in the Windows installer to get a command prompt and run the command from there.

  • Shall do. Interestingly, the hardware was fine and the computer worked until the user accidentally installed some malware (fell for the old your computer has trojans trick) and since that it's not booted. Will run the command from Windows and get back to you. Cheers! – George Pearce Jan 13 '12 at 22:23
  • If it is a mbr rootkit the malware installed, you will need to run the fixmbr command also....support.microsoft.com/kb/927392 – Moab Jan 13 '12 at 22:59
  • chkdsk worked fine - told me no faulty sectors, physically the HDD reads as okay (ignore previous comment - I was being dense). Tried Bootrec but have now returned to the first issue, we go through the boot and then re-start the process entirely. Interestingly, switching to C: on the command prompt and running 'dir' gives me "Volume in drive C is SYSTEM RESERVED. Volume Serial No is XXXXX-XXXXX. Directory of C:\. File not found' – George Pearce Jan 16 '12 at 17:18

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.