82

When I compose and send an email (I always write plain-text emails) in Thunderbird, it always truncates my sentences and adds line breaks in the middle of my sentences.

How do I turn this feature off? It is quite annoying to me.

For instance, when I send people long URLs, the URL gets cut in the middle because of the automatic line breaks.

I am using the latest Thunderbird 9 for Mac OS X

3
  • 1
    I would have upvoted but no research effort was evident.
    – null
    Commented Jan 4, 2018 at 3:20
  • 5
    @nslntmnx Sometimes it may be unclear even where to start researching.
    – Dr_Zaszuś
    Commented Apr 23, 2018 at 11:15
  • 3
    I am doing research, and this question is what I get...
    – onlycparra
    Commented Aug 11, 2020 at 7:04

8 Answers 8

70

https://help.ubuntu.com/community/Thunderbird#Disable_word_wrapping_in_outgoing_messages

Disable word wrapping in outgoing messages

  • Edit -> Preferences -> Advanced -> General -> Config Editor
  • Set the preference called "mail.wrap_long_lines" to false

See also: http://kb.mozillazine.org/Plain_text_e-mail_(Thunderbird)#Flowed_format

... mail.wrap_long_lines to control the wrapping of long lines (defaults to true)

6
  • 52
    This did not work for me until I toggled mailnews.wrap_length to zero as well. Then it worked like a charm, even with wrap_long_lines to false. This answer did point me towards the Config Editor, which is a good thing.
    – Joost
    Commented Aug 12, 2013 at 13:36
  • 1
    Moreover, I had to close and re-launch TB to make it notice the new setting. For the record, this happened with TB 24 under Ubuntu 12.04 x64. Commented Mar 11, 2014 at 12:44
  • 2
    It's enough to close the mail window (save as draft, close and reopen if you do not want to start over). Commented Jul 23, 2014 at 9:42
  • 1
    @Joost, setting the "mailnews.wrap_length" to 0, actually did fix it for me. Thanks.
    – Vicer
    Commented Mar 3, 2015 at 22:17
  • 12
    As of Thunderbird 45.1 or earlier, the mailnews.wrap_length setting is now called mailnews.wraplength.
    – tanius
    Commented Jan 20, 2017 at 21:31
13

For me, the accepted answer did not show any effect.

As Joost pointed out in his comment, the correct solution is setting

mailnews.wraplength → 0

in the config editor (Edit → Preferences → Advanced → General → Config Editor...).

2
  • I think this should be an answer on its own, as Joost's comment might be overlooked and Freeman's answer adds more settings that are unnecessary for the addressed problem.
    – Scz
    Commented Mar 24, 2017 at 13:21
  • In newer Thunderbird versions it's in Edit / Settings / (Scroll to bottom) / Config Editor
    – MKesper
    Commented Apr 8 at 20:37
12

Setting mailnews.wraplength to 0 disables wrapping on compose window, but as a side-effect does not wrap sent messages.

I addressed this problem by setting:

mailnews.wraplength 0
mail.compose.wrap_to_window_width true
plain_text.wrap_long_lines true
view_source.wrap_long_lines true
4
  • 1
    Can you give an example of how it doesn't "wrap sent messages"? I'm wondering if I should use your settings or the basic mailnews.wrap_length version.
    – Paul
    Commented Oct 25, 2015 at 16:25
  • Was there a typo in this answer? In Thunderbird 45.1.0 there's mailnews.wraplength but not mailnews.wrap_length Commented May 22, 2016 at 11:22
  • I have amended the answer to use mailnews.wraplength
    – Freeman
    Commented May 30, 2016 at 5:57
  • 1
    It may work for you, but you reported some settings that say the exact opposite of what is asked. This smells like cargo cult.
    – ceztko
    Commented Feb 20, 2018 at 0:00
8

Concerning URLs, it is actually sufficient to enclose them in < and >.

4
  • 1
    @chipperyman573 Question title: "Tell Thunderbird not to [...] wrap lines" question body "for instance [...] long URLs". One answer: put it between < and >. Not as good as the accepted one, yet a lot quicker and also working if you prefer to have the remaining text wrapped Commented Feb 16, 2014 at 8:04
  • Yeah I misread the answer, sorry.
    – Jon
    Commented Feb 16, 2014 at 8:08
  • @chipperyman573 no worries, I guess you saw it in the low quality queue, right? I'm also sometimes too quick there, that's why multiple votes are required after all :7 Commented Feb 16, 2014 at 8:14
  • 1
    Yeah, I flagged it and realized "I'm way to tired to be doing this" and took a nap. Didn't last long though sadly...
    – Jon
    Commented Feb 16, 2014 at 8:15
7

There is also an addon that can be used to disable the wrapping without messing with the configuration editor:

https://addons.mozilla.org/en-US/thunderbird/addon/toggle-word-wrap/

With this addon the wrapping can be toggled with CTRL+SHIFT+W (the message must be started in text mode, it doesn't work in HTML mode).

3
  • With Thunderbird 45.1.0 on KDE on PC-BSD 11.0-CURRENTMAY2016 I can enable that add-on but the resulting menu option is greyed out. Commented May 22, 2016 at 11:23
  • 2
    @GrahamPerrin Probably because you are in HTML mode (or switched to Text mode from the HTML mode after opening the new message) Commented May 23, 2016 at 7:53
  • 1
    OK, the underlying problem may be that I have never successfully got plain text by default. I might find a workaround/fix for that elsewhere. Thanks. Commented May 25, 2016 at 16:59
2

What I also dislike is the fact that you don't get what you see in the editor.

The visual line break in the editor which is automatically set is not visible when reading the email in the sent folder. Also received flowed plain/text emails don't show the line breaks the author could see.

I fixed it by setting mailnews.display.disable_format_flowed_support to True while still composing emails as 72 width composed for mobile device compatibility.

Since I use a widescreen display (and I guess most of the Thunderbird users do) I'm not sure if it's a good approach to turn display flowed on by default. It's just ugly to have a 1 mile long line followed by a double line break followed by next very long line and so on.

0
1

Open a msg to type. At the top Edit> Rewrap. Fixed! Found this by exploring everything when it suddenly starting happening to me.

1
  • This still adds line breaks after a certain number of characters (mostly 72). It just rearranges words when some lines are shorter. Commented Sep 13, 2022 at 9:53
1

This works for Thunderbird 91.11.0 (64-bit), tested on Linux.

mailnews.wraplength 0 => when writing, don't wrap lines after a certain number of characters

mail.wrap_long_lines true => when reading, wrap lines at window edge

plain_text.wrap_long_lines true => when reading plain text messages, wrap lines at window edge

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .