I've noticed this serious problem days ago when I was playing Star Trek Online. When playing, I switched out of the game to check IRC msgs. When I switched back, I only saw the game interface less than a second then my system crashes (no sound, monitor reports "No Signal" and numlock key failed too). I have to reset my computer. And within a day I can't even see STO's interface; the computer crash instantly after loading screens. Then when I try to use 3D window switch of Windows 7, same thing happens sometimes. I then tried other 3D games like TrackMania, and I could only see the rotating globe (3D) for a fraction of second then my computer crashed again. It seems that any 3D rendering would crash my system.

The strange thing is I could run some other applications which use GPU at 100% but with no 3D renders, like miners of cryptocurrency.

I'm not overclocking my system.
Checked CPU and GPU's temperature and both are fine.
Tried minimal system, no luck.
Tried many drivers from 275.33 to 290.xx beta, no luck. I was using 285 driver without any problems. And now I'm at 285 driver too.

System spec:
CPU: AMD Phenom II X4 940
Memory: Kingston 3 x 1GB
MB: Gigabyte MA78GM-US2H
GPU: Galaxy GeForce GTS250

Any help is appreciated, it's driving me crazy these days.


Well, I've changed a PSU and all problems solved. Looks like my PSU is too old to drive my computer.

  • Well, listening to all the fans spin up under 3D/Video loads is a pretty good indicator, eh? I've seen the newer high-end video cards drive marginal power supplies into the dirt. I wish it had been that on one system I owned, I fell victim to a motherboard and a video card who didn't like each other's bus timing. I ended up getting a new motherboard whose chipset was known to be compatible with the high end video card. – Fiasco Labs Jan 23 '12 at 8:18

It is not really an answer, but try adjusting some settings in the NVIDIA Control Panel that you think might cause the problem. Make also sure you have the latest Windows updates and the latest drivers (you can find a very large driver pack at http://drp.su/).

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.