4

I'm using Outlook 2010 on my office and home computer and have setup my email as IMAP on both.

I can't see emails older than one year.

I have tried to check the setting on both computers but can't figure out why. I don't want to archive or lose my old emails unless I delete them manually.

  • Are you sure the messages still are on the server? The server might have been set up to archive them automatically. Have you tried other IMAP clients (Thunderbird, Windows Live Mail)? – user1686 Jan 14 '12 at 20:38
  • Maybe there is a filter applied? In your inbox click on the "View" ribbon and select the "Reset View" button, or click the "View Settings" button and see if any filters are applied. – opsin Jan 14 '12 at 21:25
  • I'm using outlook 2016 with office 365 and the inbox only shows items less than a year old. there's a notification at the bottom saying "There are more items in this folder on the server - click here to view more on Microsoft Exchange". When I click that the other items appear but sooner or later they go again and the notification comes back. – Andy Jan 23 '17 at 8:50
3

Outlook 2010 uses the Auto Archive feature to keep Outlook running smoothly. It automatically stores old items outside of the Outlook Data file which meet the settings criteria you were looking at. It does not delete them (unless you choose to do so). It only store them in a seperate location.

To access archived items and to learn more about how to use it, here is more detailed information.

1

Perhaps you have auto archiving enabled? Which archives old mails to a seperate folder? This is not normal behaviour of outlook. You should provide more info or look into the settings.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.