10

I'm using VLC media player which can play almost all kinds of audio and video formats. While listening to audio, I keep VLC in minimized mode and can work on other windows. But when I select to listen video songs mixing with audio songs, VLC is maximizing itself to play every video song in the playing list, which is really annoying in the middle of work.

So how can I keep always VLC player in minimized mode while playing a list of songs mixed with audio and video songs?

7 Answers 7

5

If you want to stop it maximising when it encounters a video:

  1. Open Tools -> Preferences
  2. Click on All settings (left bottom)
  3. Interface
  4. Main Interface
  5. Select Qt interface from the Interface Module Drop-down (right side)
  6. Now in the left hand page, expand Main Interface
  7. Click Qt
  8. Change When to raise the interface to Never
  9. Press Save
  10. Restart VLC (otherwise it ignores the setting change)
1
  • Thanks @TheArchitect for suggesting #8, which seems to be affecting this behavior now.
    – sandiejat
    Oct 26, 2022 at 4:50
2

I found that VLC media player will stay minimized if you disable video playback from the settings. VLC will then no longer show videos, and stay minimized while playing your clips.

To disable video, go to Tools > Preferences (or Ctrl + P), go to Video and un-check Enable video.

If you want to see videos again, you can re-enable it from the settings.

3
  • That's really strange... as a workaround it suits most use cases, since you'd keep a playing video on top, but I use a semi-transparent term emulator over videos, and it steals focus at the worst times. Changing this setting didn't work anyway, sadly. 'Always on top' for the term breaks other things, and WM focus protection was disastrous (changing hotkeys launched a background modal window stealing inputs like escape / alt+f4 / alt+tab... I don't even remember how I got out of it.) If you can think of anything, please let me know. Cheers!
    – John P
    Jul 27, 2017 at 18:46
  • 1
    I had both video and visualizations disabled, but it opened a spare window with the last visualization I tried and stole focus anyway. I toggled those settings again and it stuck that time for some reason. I'll take a look at the source, but it's probably over my head... in the mean time, try moving VLC to a new workspace, and going through WM tweaks ('do nothing' when a window self-raises, etc.) Last resorts: alt display with ssh/X11 (unix.stackexchange.com/questions/141417/…); Linux container or VM; VLC browser plugin, back end, or TUI.
    – John P
    Jul 27, 2017 at 20:59
  • 1
    I tried moving VLC to a different Gnome3 workspace, and it stole focus from another workspace as soon as there was a new video playing from the playlist ; however, there is also Hide in Systray on Gnome 3, that seems to also prevent the VLC video window on focusing on itself
    – sdaau
    Jan 5, 2019 at 9:07
1

I found that VLC media player will stay minimized if you turn off "Deinterlacing" from the settings. VLC stays minimized while playing your clips and movies.

To turn off "Deinterlacing", go to

Tools -> Preferences (or Ctrl+P) -> Video

and choose "OFF" from menu in the "Deinterlacing" section.

0

There is a now a setting for this: Tools > Preferences > Interface:

enter image description here

Set Auto raising the interface to Never.

1
  • This didn't work for me, it still un-minimised itself. Which is weird, this menu point sounds exactly like it should prevent that. (I'm using VLC player 3.0.8 on Debian.) Oct 6, 2019 at 23:57
0

uncheck "Show systray icon" for not duplicating icon and use RBTray to move vlc completely to system tray right clicking in minimize button, resolving this problem instead.

0

After trying @user2428118 solution to uncheck Enable Video I tried simply going to the Video menu -> Video Track and check Disable. Then I could minimize VLC and it continued Playing. I find this much easier to toggle on and off vs. going to Preferences, clicking Show Settings, Video, then uncheck Enable Video.

0

I discovered that you can do it manually.

Fint the VLC icon on the right side small icons next to the date/time. If it is not there, it is hidden: click the up arrow on the left of the icons to show the hidden icons.

Then right click on it and select "Hide the..." on top.

Not the answer you're looking for? Browse other questions tagged or ask your own question.