48

I remember the manager shows a list of available plugins by default but I find it does not. Could something be wrong?

enter image description here

0

16 Answers 16

12

I find the reason.

My computer is in a LAN and the browser is using a proxy. I add the proxy for the plugin manager and update the plugin manager.

After all, it works.

enter image description here

3
12

Also, make sure the plugin manager is itself updated !

You will need to launch Notepad++ as an administrator because the plugin are saved/updated under %ProgramFiles/ which is protected

Go to Plugins / Plugin Manager / Tab Updates and check if plugin manager has an update. Relaunch and voilà.

4
  • No updates available for anything either. And under Installed tab it says Plugin Manager is version 1.3.5 (I downloaded latest version of Notepad++ today), and when I select it, the description reads Unknown Plugin - please let us know about this plugin on the forums. – BrainSlugs83 Jul 16 '15 at 22:01
  • Also, running as admin doesn't help. – BrainSlugs83 Jul 16 '15 at 22:02
  • 1
    It was 'run as admin' for me. Thumbs up! – Gishu Aug 23 '15 at 11:14
  • I've got subj error when occasionally downloaded an old version of Plugin Manager (1.0.8 while actual was 1.4.11). Downloaded last one and all is ok. – Doctor Coder Apr 6 '18 at 11:31
8

If the all of the above fail, try this:

  1. Manually download the plugin .
  2. Then from menu settings → import → import plugin, navigate to the plugin (.dll) location.
  3. Load the file.

Check the Plugin menu, the new plugin will be listed there.

1
  • Well the manual install didn't work but that turned the actual manager on while non of the other answers did it for me. – Иво Недев May 24 '17 at 21:13
7

I know this was answered a long time ago, but, a similarly-looking problem made me google, and land here.

Problem : Plugin Manager doesn't show in the Plugins Menu.

Why : You downloaded the 64-bit NPP version, and Plugin Manager doesn't support 64 Bit.

Solution : Uninstall, and Install 32 bit version.

Note : Directly from the download website, right next to the url it says that Plugin Manager won't work (lol), I didn't even read it just clicked 64-bit download, and while writing this post I figured that out. Anyhow if I missed it the first time, odds are someone else will also miss it hence my post.

1
  • No, Installed x86 version, still Plugin Manager not showing up – Himalaya Garg Jul 29 '20 at 14:48
5

Hey i had this problem,

  • the error was because i was using 1.0.8v (and this version there was no service or it was outdated)

FIX: just update to the most current version, you can find it here: https://github.com/bruderstein/nppPluginManager/releases

32 Bits or 64 Bits, i recommend users of notepad++ to use 32bits, because there's much more Plugins comparing to 64bits, you can also download both.

3

I recently had this issue on Notepad++ 7.3.1 and to fix it, I opened Notepad++ as administrator, navigated the menus Plugins > Plugin Manager > Show Plugin Manager, then go to the Installed tab, select "Plugin Manager" and click Reinstall. Notepad ++ restarts and then the plugins list loads properly.

After which, you can update Plugin Manager using the same dialog under the Updates tab.

3

This happened to me after installing Notepad++ from chocolatey. But there was a solution right in the plugin manager itself, hidden under Settings button.

Place empty file called allowAppDataPlugins.xml in the Notepad++ directory.

(Meaning the directory where notepad++.exe is, mine was in standard C:\Program Files (x86)\Notepad++.)

After I created this file (just copy and rename readme.txt for example) and restarted Notepad++, plugin manager was showing plugins again.

enter image description here

2

All solutions did not work for me and/or were too much complicated.

This did the trick:

  1. Open Plugin Manager
  2. Settings
  3. Enable these checkboxes (maybe one of these is enough [I guess the HTTP one])
    • Show unstable plugins
    • Force HTTP instead of HTTPS [...]
    • User development plugin list [...]
  4. OK

List is refresehed and filled.

Open Settings again and change back to your previous/prefered configuration. List will still be filled.

1
  • 1
    For me it was specifically "User development plugin list [...]" that made a difference, and changing it back made the list disappear again. – Stephen Dec 13 '18 at 3:14
1

I enter the proxy that my web browser was using in my corporate environment and it worked.

I didn't need to enter a port number but it depends on your proxy configuration!

Compare is an indispensable plugin, especially when comparing Cisco router configs.

1

I had this issue but it turned out to be quite simple, the firewall was blocking it.

Important:

When the plugin manager can't connect it will still say no plugins available. Once it receives its first list it will display the same list even if it can't connect. It loads them in as though it just connected but it actually hasn't. This should be improved.

1
  • 2
    How would someone find out if their firewall was the problem/what would they need to do to fix it? – tgies Apr 9 '14 at 17:15
1

Add manually plugin manager then its works.

https://sourceforge.net/projects/npppluginmgr/

0

Try changing the language to "English". It worked for me.

0
0

This may be just another reason to have a play in the game. If you do not use internet explorer / egde anywhere around your machine and furthermore / nevertheless set your (windows / internet options) cookie policy to "ask" for first and "block" for third party cookies,
np++ plugin manager will also fail to download the plugin list.

See the following screenshot for the AppData\Local\Microsoft\Windows\INetCache folder, showing cookies and management data.

There seems to be no other workaround than activating first and third party cookies temporarily along with np++ plugin manager usage (and delete / reset back afterwards).

0
0

{for notepad++}download plugin manager and then extract it then find "pluginmanager.dll"copy the file and paste it in C://program files(x86)/notepad++/plugins..[here].(if plugin manager is already there--simply skip this.--) https://sourceforge.net/projects/npppluginmgr/

then download python script plugin, and install it, extract it whatever process(you will be guided)then find "pythonscript.dll" copy the file and paste it in c://programs files(x86)/notepad++/plugins.....done. https://sourceforge.net/projects/npppythonscript/?source=typ_redirect

now you are ready to rock..

1
  • 1
    Please update answer so it quotes links, but is not dependent on them, so all important content will be in the answer even if links stop working. – miroxlav Sep 7 '17 at 1:11
-1

Add a file called - allowAppDataPlugins.xml To - C:\Users\Administrator\AppData\Roaming\Notepad++

restart Notepad++

Fixes most issues

2
  • "allowAppDataPlugins.xml" Where does this file come from? What should it contain? – DavidPostill Jan 26 '17 at 12:22
  • It should be empty. Notepad++ uses this file as a configuration flag... If it is present, Notepad++ will look for plugins in the AppData directory. Otherwise, it won't. – daveloyall Feb 16 '17 at 22:43
-1

I faced the similiar problem. The issue is your OS's firewall is preventing notepad ++ from connecting to the internet. So go to your firewall setting and add exception for the "Notepad++ " .

0

Not the answer you're looking for? Browse other questions tagged or ask your own question.