11

Yesterday, I downloaded SQL Developer 3 with SDK and was able to use it just fine. After shutting down my PC last night and booting it up again this morning, every time I try to run it, I get this message:

"Enter the full pathname for java.exe"

I browse to C:\Program Files\Java\jre6\java.exe where the EXE is located and I get this message:

"Cannot find a J2SE SDK installed at path C:\Program Files\Java\jre6\java.exe"

What could be the issue here when it was working just fine yesterday? I will add that my PC did freeze last night during shutdown, so I ended up having to power it off, but I don't know if that's relevant.

I reinstalled Java and it still gives the same message. I also downloaded SQL Developer without the SDK and get the same message. I will also add that I am not actually installing SQL Developer, just running the executable from the folder. I don't think you actually install it anyway.

Anyone know what could be causing this? I am on Windows 7 32-bit.

1
  • I appear to have fixed it my uninstalling Java and deleting the SQl Developer program folder. I then reinstalled Java and re-extracted SQL Developer and it works now. Before I put this as my answer, I'll see what everyone else has to say, if anything. – oscilatingcretin Jan 17 '12 at 15:10

13 Answers 13

7

"jre6" in the folder name implies you have JRE installed there, and not the SDK. Point it to somewhere where you have java.exe of a JDK/SDK installation, instead of JRE, and from thereon it should work.

If you had to power off during shutdown, it might've not been able to save the SDK reference, thus asking it on the next startup.

1
  • 2
    After booting up my PC again today, I was greeted with the error message yet again! I searched my C drive for java.exe and found out that there was a copy deep in the folder that I extracted the ZIP file I downloaded. Specifically, it was in sqldeveloper-3.0.04.34\sqldeveloper\jdk\jre\bin. I pointed it to that and worked! – oscilatingcretin Jan 18 '12 at 17:48
4

If your jdk file gets stuck on asking for the jdk file on repeat in windows 7, or you are having problems with the jdk file, try running SQLDeveloper as administrator rather than just the regular startup.

2
  • This was my problem. I also recommend that you only open as administrator the once, set the Java path, close and open as normal. You shouldn't need to run as admin more than once. – Dan Atkinson May 2 '13 at 9:46
  • Sounds like my issue - not giving me an error when I point it to a jdk, just asking again with a fresh, empty dialog -- what do I do if I can't run as administrator? – Code Jockey Jun 12 '19 at 18:34
3

Resolved. It didnt work for me but after spending lot of time , here is what what I did to fix it.

1) Open the file

..\sqldeveloper\sqldeveloper\bin\sqldeveloper.conf 

and add the following line to set jdk path:

SetJavaHome C:\Program Files\Oracle\11g\product\11.1.0\client_1\jdk

If it don’t allow you to save the file, copy whole sqldeveloper folder to a different location where you have write access to modify this file.

2) Run sqldeveloper.exe (from the new place if you moved the folder out from oracle folders) as administrator and enter the jdk path that comes with your oracle installation:

C:\Program Files\Oracle\11g\product\11.1.0\client_1\jdk\bin

It should work then... hope it will help you save hours. - snehal

1
2

you can download one here: http://www.oracle.com/technetwork/java/javasebusiness/downloads/java-archive-downloads-javase6-419409.html#jdk-6u34-oth-JPR. I downloaded and installed 32 or 64 bit

2

I encountered the following message repeatedly when trying to start SQL Developer from my installation of Oracle Database 11g Enterprise: Enter the full pathname for java.exe.

No matter how many times I browsed to the correct path, I kept being presented with the exact same dialog box. This was in Windows 7.

The solution was to right-click on the SQL Developer icon and select "Run as administrator".
I then used this path: C:\app\shellperson\product\11.1.0\db_1\jdk\jre\bin\java.exe

1

Try entering the full path to java.exe while using SQL Developer. For example:

c:\app\shellperson\product\11.1.0\db_1\jdk\jre\bin\java.exe
1

Try setting the path below. It worked for me.

C:\Program Files\Java\jdk1.7.0_79

To cross check, you can check the path specified to locate JVM in the configuration file:

..\sqldeveloper\sqldeveloper\bin\sqldeveloper.conf 
0

If you are in 64 bit environment, you need to install the latest java 6 SE for 32 bit and use that (oracle calls these versions i586 eg, Jdk-6u45-windows-i586.exe).

0

I found the file(sqldeveloper.conf) in this path

D:\app\admin\product\11.2.0\dbhome_1\sqldeveloper\sqldeveloper\bin

and then I set the javahome like below, previously it was pointing to the jdk1.7

SetJavaHome C:\Program Files\Java\jdk1.6.0_06

2
  • 1
    The key point is that it is D:\app\admin\..., because the user is admin, so it will be changed according to the user. And where to look in your pc , the location can be found in the 'path' environment variable'. It is like that in my pc : D:\app\admin\product\11.2.0\dbhome_1 – Manoj Kumar Apr 19 '15 at 6:53
  • You can include you explanation in the answer itself. There is no need for mentioning it separately in the comment. Answers explained in details are always welcomed. :) – Ayan Apr 19 '15 at 12:23
0

When SQL developer asks for Java path, mention the path as including java.exe also:

C:\Program Files\Java\jdk1.6.0_06\bin\java.exe

This worked for me.

1
  • Can you clarify your answer- do you mean editing the $PATH variable to include the location you mentioned? If so, how? – bertieb Aug 11 '15 at 10:05
0

there is some conflict between communicating between java and oracle so oracle is installing an specific java for it self .

try to insert this address :

[ORACLEHOME]\product\12.1.0\dbhome_1\jdk\jre\bin\java.exe

remember [ORACLEHOME] means where your oracle has installed

0

If you are running Windows 10 and need some old SQL Developer version ( Like 3.2), you may need to install the JDK jdk-7u79-windows-x64.exe or older ( not the latest ). I had installed the latest version and got the error can't find .... After installing the old JDK version I could able to install old SQL developer version ( 3.2 )

You can get old JDK from this link https://www.oracle.com/java/technologies/oracle-java-archive-downloads.html

Hope this helps

-1

Check your sqldeveloper.conf file. It contains:

SetJavaHome ../../jdk

This means when SQL Developer starts up it will look in the ../../jdk folder for java.exe.

Once you've installed a version of JDK, copy the folder to ../../jdk location relative to the sqldeveloper.conf file (which you can find in /bin folder).

/installed folder
    ...
    /dataminer
    /ide
    /javavm
    /jdk   <== create this and copy jdk stuff here
    ...
    sqldeveloper.exe

...

then you won't be prompted with the question.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.