My problem is that my PC restarts while booting. The BIOS shows up, it shows that all HDDs are found and RAM is checked. But when the XP booting screen should appear, my PC just restarts and starts all over again. I tried to reinstall, but it freezes and I also tried to launch an Ubuntu Live CD, but it also froze. Could some one tell me what the problem is?

The problem is that I can't get to the Live CD main menu, so I can't run any memory tests. I also tried to run memtest from usb but it doesn't work either.

Futher information (18/01/12):

I turned my PC on this morning, went into the BIOS and set it restore default settings. After that it restarted and now it dont recognize any of the two HDDs.

I tried to find HDD on bios manually and automatically but neither of them worked. I tried to disconnect all the wires and put them all back as they suppose to be, but still nothing.

The PC is old - it's a P4 2,4Ghz and an unknown Gigabyte motherboard. I have no clue how to change or update BIOS.

  • FYI @Naurius, I merged your two unregistered accounts for you, so you should now be able to edit your post. If you want to be able to retain ownership of your questions, you can register your account by clicking the "my logins" link on your user profile. – nhinkle Jan 18 '12 at 19:13

My first step in a situation like this is to reset the BIOS back to factory. Get into the BIOS screen and just set defaults, save and reboot, see if that helps. If not... Look for a setting under hard drive compatibility that has to do with IDE mode, AHCI or combination mode. Depending on what option is currently selected, try the other options. This most likely isnt the case being that Live CD's arent working either, but cant hurt to try it. Sometimes if you load the PC with an IDE type mode enabled, and the system reverts to AHCI, the system wont boot. If this still proves fruitless...

Move on to disconnect all unnecessary hardware from the PC. External drives, extra monitors, etc and try booting again. If it still won't boot, remove any and all peripherals and expansion cards, such as Modems, NICs, video cards (if your PC has on board video you can use in its place), and all but one stick of RAM. Try booting again. If it boots, great, return things one at a time until the problem recurs to find the problem. If it still doesn't boot swap RAM in until you've tried all available pieces. If all pieces are tried, or if you only had one piece, and it still isnt booting, EVEN into a LIVE CD, its time to start looking at possible bad components... PSU, CPU, Motherboard etc.


It sounds like there is a hardware issue of some sort if it reboots even when you try a live CD. You may want to run a memory test from the live CD if there is one on the boot menu or grab a different live CD for that test


This sounds like a RAM or a logical CPU issue. Try systematically removing and interchanging your memory modules 1 at a time. This may be lengthy but it could easily diagnose your issue.

Also, there is a possibility your main CPU is overheating. Try getting into your BIOS (instructions to enter BIOS should be shown during POST - or when you turn your computer on right away). Depending on your BIOS revision, you should be able to find a PC health or monitor section in your BIOS. The default cut off temperature is 90 Degrees Celsius. This prevents any major damage to your motherboard and CPU. If this is your case, check the heatsink, fan, and thermal compound between the two.

  • Typically an overheat event triggers a shut down. Not a restart. i wouldn't rule this out completely, but it would be low on my list to check. – Paperlantern Jan 17 '12 at 20:17

You probably have a hardware problem, mostly likely a Machine Check Exception (quote from Wikipedia, slight formatting changes):

A Machine Check Exception (MCE) is a type of computer hardware error that occurs when a computer's central processing unit detects a hardware problem.

Microsoft Windows displays the error using the blue screen of death containing the error message (the parameters inside the brackets vary):

STOP: 0x0000009C (0x00000004, 0x00000000, 0xB2000000, 0x00020151) "MACHINE_CHECK_EXCEPTION"

On Linux, a process (such as klogd(1) ) writes a message to the kernel log and/or the console screen (usually only to the console when the error is non-recoverable and the machine crashes as a result):

CPU 0: Machine Check Exception: 0000000000000004
Bank 2: f200200000000863
Kernel panic: CPU context corrupt

This is consistent with your experience, because a Windows system would reboot by default on a Stop error caused by this problem and a Linux system that experiences a kernel panic while booting with the graphical splash screen would freeze.

According to Wikipedia, causes of MCEs can include:

...overheating and/or incorrect hardware installation. Some specific manually-induced causes could include:

  • overclocking (which normally increases heat-output)
  • poorly fitted heatsink/computer fans (the same problem can happen with excessive dust in the CPU fan)
  • an overloaded internal or external power supply (fixable by upgrading)

Computer software can also cause MCE errors (normally by corrupting data which programs read or write). For example, software performing read or write operations from or to non-existent memory regions can lead to confusion for the processor and/or the system bus.

To confirm that an MCE is occurring, hold F8 before the system boots Windows and select Disable automatic restart on system failure. If you receive a Stop error with code 0x0000009C as above, an MCE has occurred. If not, some other problem has occurred. Post the Stop error code as an edit to your question if one appears; if not, tell us what happened when you tried again.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.