13

I was browsing the web with Chrome and pressed f. A search box appeared. I then pressed s, after which Chrome asked if I wanted to save the web page.

I soon realized that my PC was thinking that I was constantly pressing the Ctrl key regardless of what program I was using.

In response, I tried clicking both of my Ctrl keys a few times to no avail.

This problem arises sporadically as I work. I am not sure what is triggering it.

Why could this problem be occurring? Is it the keyboard or software? How should I respond?

8

This could be caused by the 'Sticky Keys' function (an accessibility option). If you are on Windows 7, click on the start button go to Control Panel, ease of access, change how your keyboard works. Under the option 'Make it easier to type', uncheck 'Turn on Sticky keys' and see if this solves your problem.

  • @DavidFaux Great! Thanks for letting me know. – dwolters Jan 23 '12 at 19:44
8

For me, this seems to happen when some other program intercepts the controls while your using the Ctrl key. In my case if I am working in LogMeIn and I have the Ctrl key down and an email alert pops up, the Ctrl key will be "Stuck" Until I tap it again.

If it continues to be stuck even after pressing it, you may want to run in diagnostic mode by running msconfig, then selecting Diagnostic startup. Start the services and programs you need manually and see if it still occurs.

2

Ran into another problem exactly like this one, but the cause was completely different.

Go to Device Manager and search for the section named "Keyboards". Under this tab, if there are two "HID Keyboard Device" entries, right-click and uninstall one of them.

  • I have this problem (ghost continuously pressing the 1 key) with an older Dell Laptop (Inspiron N5010). Your idea didn't work for me directly. Windows 10 automagically reenables both HID Keyboard Device and the Standard PS/2 Keyboard. I tried deleting all of them and rebooting (all 3 are then magically reenabled), and that seems to have helped -- but it still does it on startup, which is really annoying. However, once logged in, I haven't seen the behavior persist. – bearvarine Jul 4 '18 at 19:24
1

For me it it gets fixed by pressing Fn and the Windows key at the same time.

0

**This is not a sticky keys issue or a hdwe issue.

It's a windows software issue--look it up.

MS does not know how to solve it. It's been going on for years.**

  • 2
    Some proof of this would be nice - or as XKCD would say citation needed – Journeyman Geek Aug 27 '13 at 1:59
  • @JourneymanGeek I've had Sticky Keys disabled for years, yet I still encounter this problem every once in a a while. I think Jeff's answer is closer to the real answer, and probably also what hrn meant. – Aske B. Jun 14 '15 at 8:51
0

I had a stuck Alt key happen to me once on a Samsung Chromebook using LogMeIn.

I was able to get it unstuck by pressing the "Magnify" Key (above the Shift key).

Not the answer you're looking for? Browse other questions tagged or ask your own question.