I have a 3TB Seagate GoFlex External HDD. When I first got the device, it would show up as Removable Storage in My Computer where I could right click on the drive and eject it when I was done. However after creating some partitions and formatting the drive stopped showing up as Removable Storage. I reverted my changes and went back to a single partition but it still registers as an Internal Hard Disk on all my computers.

The biggest problem I have with this is that I cannot eject it. I either have to turn it off by unplugging it since there is no power switch, or just unplug it from the USB. I'm worried about data corruption so I've since stopped using the drive.

I came upon another thread here: USB stick appearing as hard disk drive, not removable storage device

However the program, BootIt, that the author of the post refers to does not fix my problem. I tried turning on the "removable bit" numerous times but to no avail. Any ideas on how I can set this as a Removable Drive? Or revert the hard drive back to a factory state?

  • Any way to test it on another PC to see what it does? – HaydnWVN Jan 18 '12 at 11:19
  • Yeah, I've tried it on my laptop, desktop, friends computers and my work computers. All the computers says the same thing "Internal Hard Disk". I'm guessing its a problem with the drive it self, I must have deleted something during the re partitioning and formats. – Mr.X Jan 18 '12 at 23:20
  • For this reason I always take an image (currently using Acronis True Image) of every new external drive I purchase - sorry that it's not much help to you after the fact – Shevek Jan 19 '12 at 12:49
  • Shevek - I had no idea that you could even do something like this (which is probably why I'm in this mess). When you say "take an image" does it back up everything that's on the drive? Or just the partition(s)/File system structure? – Mr.X Jan 19 '12 at 19:01
  • Acronis can do both. I create an image of the entire drive which includes partition tables, MBR, partitions and data. – Shevek Jan 19 '12 at 22:54

My source: http://www.uwe-sieber.de/usbtrouble_e.html#partitioning

I know it talks about flash drives, but the 'removable bit' is common between all USB removable drives.

Nearly all USB flash drives pretend to have a removable media
(even it's a lie), so Windows detects them as 'removable'. On 
drives with a removable media Windows 2000 and higher supports 
only one partition.
Finally it's a single bit in the device's device descriptor, 
the removable media bit (RMB). If you take away the RMB then 
Windows sees the drive as 'local disk' and multiple partitions 
The Removable Media Bit can be changed either in the drive's 
hardware or by a Windows filter driver.

Lexar BootIt is mentioned in many places for changing the RMB, but be warned: A couple of places i've read it can damage USB-pendrives (i'm guessing the RMB on these devices is hardware coded in some way). In theory you won't have a problem as you've already successfully removed it.

opsin makes a good point about reinstating the original software/filesystem on the device, in theory returning it to factory settings will restore the RMB bit. My guess is that windows removed the removable bit when you created multiple partitions followed by formatting.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.