I installed Archlinux recently. I have instaled flash, vlc, alsa-utis. But there is no sound.

I tried un-muting using alsamixer but there are no difference. Can you please let me know how to fix this issue?

"sudo aplay -l" results in the following output:

**** List of PLAYBACK Hardware Devices ****
card 0: Generic [HD-Audio Generic], device 3: HDMI 0 [HDMI 0]
  Subdevices: 1/1
  Subdevice #0: subdevice #0
card 1: SB [HDA ATI SB], device 0: CONEXANT Analog [CONEXANT Analog]
  Subdevices: 1/1
  Subdevice #0: subdevice #0

Sound card: ATI Technologies Inc SBx00 Azalia (Intel HDA) rev 40

  • 1
    you tried to check if it works with headphones? And please post more details about your proble. For example the name of your soundcard! Did you tried to run alsaconf? – Ivan Jan 18 '12 at 21:17
  • Headphones did not work either. How to probe? I did run alsaconf now and it said it successfully configured. Should i reboot my machine after this? – 18bytes Jan 18 '12 at 21:30
  • mmm not sure, but try to reboot. – Ivan Jan 18 '12 at 22:04

I struggled with alsa when using Arch, and have always opted to use OSS instead

OSS Advantages;

  • Per-application volume control.
  • Some legacy cards are supported better.
  • Initial response time in sound applications is usually better.
  • Better support for applications that use the OSS API. Many applications still use this API, and do not require an emulation layer like ALSA uses.

Simply follow the install guide

| improve this answer | |
  • 1
    OSS worked like a charm, i just followed the install guide. In 5 minutes it was working! Thanks! – 18bytes Jan 26 '12 at 14:55

If you are using i686, try the linux-lts kernel. I use an ancient audigy 2 ZS soundcard with snd_emu10k and it will not produce sound with the later kernel versions.

If you are using x86_64, I have no sound using the 3.5.3-1 kernel because the ALSA does not see the sound devices as user. Earlier kernels did work.

Bugs have been filed at bugzilla.kernel.org.

| improve this answer | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.