8

I have a problem with junk mail filtering in Thunderbird and I just want to turn it off completely; however as far as I can see it's not actually enabled anywhere; and further to that I went into my server and added to the whitelist one email address in particular (which is constantly being marked as junk in Thunderbird). I did this just to rule out the mail server as a possible culprit, but I didn't think it was anyway because a) I think it is currently set to delete junk, and b) I think that when mail servers don't just delete the junk they mark it with SPAM or something in the subject.

So the things that I have done to turn off junk mail are the following:

  1. Account settings > Junk settings > unticked "turn off adaptive junk mail ... " ( this I would have thought would have done the trick alone but not so) ... I also did this under local folders just in case that was what was doing it.
  2. Checked "Do not mark as junk mail if the sender is in .." ticked all .... and the sender is in all too. I know this shouldn't matter in light of 1 but I did it anyway.
  3. Checked for a message filter under tools>>message filters. Only my own ones are there.
  4. Tools>options>>advanced>>junk unticked everything (and also clicked "reset training data" in case that was it)

I can't think of anything else but I have read some posts on the internet where others are having a similar problem. I have been a happy user of Thunderbird for about 5 years now but unfortunately if I can't fix this I'll have to switch to something else, who knows what, as it's actually unreliable as it is.

  • Are you saying that the emails are still moved to the Junk folder? Do they have the "junk" flag on when they get there? – Paul Jan 19 '12 at 1:59
  • Yes they are still moved to the junk folder; and they have a junk flag and a button for me to press "not junk" – byronyasgur Jan 19 '12 at 15:58
  • I can't see how that is possible! I would be inclined to think your profile has become corrupted somehow, it certainly isn't normal behaviour, and isn't something I have seen in all the mess-ups I have experienced with Thunderbird. Could you create a new profile for testing and see if it does the same thing? – Paul Jan 19 '12 at 21:17
  • Thanks Paul. I was thinking possibly something might have gone askew somewhere - I thought it might have something to do with the program either - so I was thinking i might just reinstall it again, as I am using Imap - I dont think it will be a big chore. – byronyasgur Jan 20 '12 at 21:19
  • Sure but reinstalling thunderbird will not make any difference to a corrupt profile. – Paul Jan 21 '12 at 0:16
2

This video explains all... it's under Tools -> Account Settings. Each individual accoutn has its own junk mail settings, so go in there and uncheck the box:

https://www.youtube.com/watch?v=k7KrnFVVYBY

  • 3
    Didn't the user say he'd done that? If the YouTube video actually addresses the problem, you shoud summarize here. – Isaac Rabinovitch Oct 30 '12 at 1:04
  • 3
    The profile seemed to be corrupt, I haven't had this problem since I created the new profile – byronyasgur Oct 31 '12 at 15:43
0

Create a new profile and reconfigure your mail settings.

The answer from the OP @byronyasgur was left in a comment:

"The profile seemed to be corrupt, I haven't had this problem since I created the new profile"

protected by Ramhound Feb 15 at 23:05

Thank you for your interest in this question. Because it has attracted low-quality or spam answers that had to be removed, posting an answer now requires 10 reputation on this site (the association bonus does not count).

Would you like to answer one of these unanswered questions instead?

Not the answer you're looking for? Browse other questions tagged or ask your own question.