This may belong on SF, migrate if it does!

Pinging with 32 bytes of data:
Reply from Destination host unreachable.
Reply from Destination host unreachable.
Reply from Destination host unreachable.
Reply from Destination host unreachable.

Pinging a windows machine on my home network with the IP, Windows is trying to get replies from The machine I am pinging has an automatically obtained IP and it can access the internet fine. The machine I'm pinging from is able to ping any other machine on the network just fine.

I've never encountered anything like this before.

Can anyone shed some light? Why would this be happening?

Things I haven't tried yet:

  • Rebooting router
  • Rebooting my machine
  • Rebooting target machine (or renewing target IP)

Edit: Pinging any "unassigned" IP on the network will try to get replies from my own IP ( will try to get replies from my own IP) - thanks to regan's answer for pointing me that way. I'm 100% sure this machine is connected to the same network and there is no firewall active.

  • this is how it's supposed to work – davr Sep 9 '09 at 0:40
  • @ Ciaran - you may want to mention that your own IP, in the example above, is – J. Polfer Sep 9 '09 at 13:36

To shed some light:

  • When you can't ping the IP of a machine, your own IP says it is unreachable.

Things to try:

  1. Try the things you haven't tried yet to clean out possible clutter in an easy way.
  2. Try to ping the target machine from another machine to see if the target machine is the problem, if the other machine succeeds them the problem is more likely on your machine than on the target machine.
  3. In the case that the target machine is the problem, you might want to run the following command as an administrator to enable pings: netsh firewall set icmpsetting all enable
  4. If the case that your machine is the problem then it is a weird case, for some reason it doesn't see the target machine but still sees the other machines, but that is a case that normally isn't so common.

Please let us know if this helped or if you have more details. For more information and other possible less general causes, see this on Google: "Destination Unreachable" site:microsoft.com

  • Thanks! So its by design. Learn something new every day. – Ciaran Sep 11 '09 at 21:07

Make sure the firewall on your target machine isn't blocking ICMP requests.

Is your machine's IP address? I tried pinging an unassigned IP address just now and the "replies" came from my own IP address.

  • 1 is actually my IP. There is no firewall. I am 100% sure the address is assigned (I have physical access to this machine) – Ciaran Sep 8 '09 at 21:46
  • Can you ping .4 from .5? As regan said, if it is saying your local machine is returning it as unreachable, that means that the echo request (ping) was never returned by .5 – MDMarra Sep 8 '09 at 23:04

Are your devices plugged directly into the router or is there a switch in between? I would recommend rebooting the switch or router they are plugged into, as I've seen it where the MAC address table get "confused" for lack of a better term.

  • Everything's wirelessly connected to a router. Nothing in between. I don't really want to reboot anything just yet, I just want to know if there's a reason for this happening. Some RCA if you will – Ciaran Sep 8 '09 at 22:00
  • Gotcha. You mention being able to connect to other wireless devices on the network — are all these devices connected wirelessly? I ask because there's often a setting on wireless routers for whether clients can connect to one another. – emgee Sep 8 '09 at 22:33

As said above, is your address.

I'm going to go out on a limb here and guess that is a windows machine, and the ICMP filtering in the Windows firewall is enabled. By default(?) Windows firewalls are set to drop ICMP echo requests, on the theory that if you can't ping 'em, the bad guys won't know the system exists and can't apply the windows vulnerability du jour. Of course this means that the bad guys don't bother with ping probes any more and just send the vulneability du jour out to random IPs hoping to get lucky.

If .5 is an XP system, go to the Control Panel -> Network Connections -> Local Connection -> Advanced -> Firewall Settings -> Advanced -> ICMP Settings ... and look at Allow Incoming Echo Request. I suspect it isn't set.

This "feature" causes some hilarity with some DHCP servers which ping IP addresses before offering them as leases, on the theory that if something answers the ping, the IP address isn't allocatable. However, if things on the network no longer answer pings, you start getting IP address conflict fun.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.