I recently upgraded one of my machines to Snow Leopard. This had the side effect of removing all custom drivers for my printers, and I've been unable to get the "Intel Mac OS X" GDI driver from OKI's site working.

The installer runs through the motions and sticks a few drivers in /Library/Printers, but when I attempt to load those drivers through the printer interface it simply reverts back to "Generic Printer". The drivers are not listed in the chooser list.

When I attempt to print via the GP driver the printer does not react. I am able to print from other computers (both Windows Vista and Ubuntu 9.04). The printer is networked and (should) supports IPP.

What should I do?


Snow Leopard made many Oki printers obsolete because Apple is no longer allowing drivers that were written in the Carbon programming language. As of September 9, 2009, Oki has stated that they are working on a new driver solution. As of 13/9/2009, you have three options:

  1. Wait. Oki is writing a new driver written in the Cocoa programming language.
  2. Downgrade. Snow Leopard is not currently compatible with your printer.
  3. Get a new printer with better OS X support.

For more information, see this link: http://my.okidata.com/pp-C3200n.nsf/openingdrivermenu?OpenFrameSet


I had the same problem with my Oki C3200n. All solutions I could find in the www did not work. But then I could solve the problem by downloading the unix open source drivers under http://foo2zjs.rkkda.com/foo2zjs.tar.gz and following the instructions given in the file "INSTALL.osx" by Rick Richardson 02/21/08 from point 1) to 5). This results in the 64 bit compilation of the open source printer drivers. The last step was to select the driver "Oki C3200 Foomatic/foo2hiperc" in the printer section of the snow leopard system settings.


Minutes after posting my question I found the answer, I was using the wrong protocol: was trying to use TCP IP, was supposed to use LDP.

Thank you Bernhard for the solution, it works wonderfully and does not leave me at the mercy of Oki or Apple :)

Cheers! Kasia


I do not know about USB, but if your printer is connected to a network via ethernet then the c5650 driver from baltic.oki.com will work. I just tried both color and b&w and both printed fine. Nice to have my printer back after four months.


From here:

Question: Why with the release of Snow Leopard (10.6), do certain GDI printer drivers as well as PostScript printer plug-ins no longer work?

Answer: This is due to a change in the allowed programming languages for 10.6. Apple stopped allowing any drivers and/or plug-ins that were written in the Carbon language from working under a 64-bit application. Going forward, all drivers and plug-ins must be written in the Cocoa programming language in order to have full compatibility with both 32-bit and 64-bit applications.

Since most of our GDI print drivers are written in Carbon they stopped functioning with the release of Snow Leopard. However, if the newest version of most Oki GDI printers is used basic print functionality is still available under a 64-bit app, while full print functionality is available under 32-bit apps. Although these drivers allow for basic printing under 64-bit apps (eg. Paper Size, Layout, etc..) printer specific features (Color Settings, Duplex, Tray Source) are not available and will be crossed out. (See image below for an example)

enter image description here

64-Bit Workaround

Most of the native applications in Snow Leopard launch in 64-bit mode. This will prevent any driver written in Carbon from providing full functionality. A workaround to this is to launch the application in 32-bit mode. The steps below demonstrate how to do this.

Important Note: For the steps below to be successful, the proper driver version must be installed (See chart under Driver Version Support), and Rosetta (Free download from Apple) must be installed

  1. Using the Finder, browse to the Applications folder

  2. Get Info on the application to be launched (Command (Embedded image moved to file: pic10555.gif) + I) or (Secondary Click -> Get Info)

  3. Check the box that says "Open in 32-bit mode" and then close the "Get Info" window

    enter image description here

  4. Launch the application normally, and full print functionality is now available

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.