13

I'm running torrents on the home server, and I talk to home server via the transmission-remote utility. I'd like to retrieve the magnet link for one of my torrents, however this seems to be impossible, as the transmission-remote -t[torrent-id] -i doesn't give me the link, and the manual also says nothing. Is there any way to get a magnet link?

8

May have been patched since the question was asked, but running

transmission-remote -l -t 13 -i | grep magnet

worked for me, got the magnet link for torrent number 13.

If you want only the link, you can sed away the title:

transmission-remote -l -t 13 -i | grep magnet | sed -e "s/^ *Magnet: //"

You may need to add a parameter --auth <username>:<password> for authentication.

2
  • In my version of transmission it doesn't work, but it's outdated, so I'll have to just believe you ) Thanks for the solution )
    – Septagram
    Apr 10 '14 at 12:07
  • Running 0.8.5 (from gentoo net-p2p/bitcoind-0.8.5:0)
    – Puggan Se
    Apr 10 '14 at 12:20
5

This worked for me :

transmission-remote -a magnet:?xt=urn...[magnet_link_here]...
0

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.