12

Is there any way to prevent iTunes from starting on a Mac under OS X Leopard when an iPhone is plugged in?

15

Or open System Preferences -> Accounts -> Login Items and remove the "iTunesHelper" entry.

  • I figured that would do the trick, and it does. But I wondered if there was another way I was missing. – ongle Sep 9 '09 at 3:09
  • 2
    The other way would be to plug your iPod/iPhone and choose the device from the side panel. There make sure you are on the "Summary" tab and uncheck the option: "Automatically Sync when this ihone is connected". This method works only for your device and not for any other you might plug in, unless of course you uncheck that option for all of them. – Tiago Veloso Sep 9 '09 at 7:44
  • I was able to prevent automatic syncing by deselecting the correct option in iTunes preferences, but iTunes itself would still start up (which slowed things down, used up memory, and generally was annoying). – ongle Sep 15 '09 at 22:34
3

Open iTunes> Preferences>Devices>General tab and check "prevent iPods [etc] from automatically syncing"

http://forums.ilounge.com/showthread.php?t=157512

  • I don't see an 'iPod' preference page, perhaps that is on the Windows version. – ongle Sep 9 '09 at 2:56
  • The pane is called "Devices" on a mac. The option is calles "Disable automatic syncing for iPhones and iPods". – Wolf Sep 9 '09 at 10:26
  • I see. I already did disable synching, but iTunes itself still launched when the device was plugged in. True to its word though, it didn't sync. – ongle Sep 15 '09 at 22:35
  • I don't see this for iTunes v.9 on Windows. – Marcus Leon Oct 14 '09 at 18:03
  • This doesn't actually work; my apologies for editing and upvoting. – davetron5000 Dec 6 '11 at 14:38
2

On OS X 10.8 Mountain Lion this option has moved very slightly. Find it under:

System Preferences -> Users & Groups -> Login Items

Then remove the iTunesHelper entry.

0

I prefer it like this:

  1. go to iTunes -> Preferences
  2. select Device tab
  3. check the prevent iPods,iPads from syncing automatically

This should solve this issue.

Your Answer

By clicking "Post Your Answer", you acknowledge that you have read our updated terms of service, privacy policy and cookie policy, and that your continued use of the website is subject to these policies.

Not the answer you're looking for? Browse other questions tagged or ask your own question.