Most of the questions on this topic related to folks connecting to somebody else's wireless network when their own was available and could remedy the situation by going to their connections and unchecking the "connect automatically" box. See this: " Avoid automatically connecting to wireless network on windows 7 " as an example.

In my situation, I've noticed that Win 7 will automatically connect to any unsecured wifi network - even if I have never connected to it in the past. If I am traveling and boot Win 7, it will start and connect to what appears to be the best signaled unsecured network without prompting me for confirmation (note: in the above link, "Naveen" seems to have same problem). Obviously, that is a security concern to me.

Further, when I open "Network and Sharing" and "Manage wireless networks" the network is not displayed (probably because I labelled it a public network). Again, these are new, never connected with before, wireless networks. I always promptly disconnect from them but don't want to have to be on constant guard for an auto connection to a malicious network.

This began about a month ago, as I recall, Win 7 did not behave like this in the past, I didn't monkey with wifi settings, and don't use a 3rd party connection manager. I did have to download some internet security certificates for army website access but I don't think that should mess with network settings.

Any ideas how I can tell Win7 cease automatically connecting to networks or, at least, to prompt me for a confirmation before connecting?

  • Note: At home, Win7 will connect to my home network and not other nearby networks (things seem to work fine at home). – Xtend Jan 20 '12 at 19:25
  • Welcome to Superuser. Since it worked correctly before, and just to be safe, you might want to run a full virus and malware/spyware scan to make sure something isn't automatically connecting you to any open network. Here is a good posting of how to do that. Go here. – CharlieRB Jan 20 '12 at 19:45
  • @CharlieRB Thanks. I have a virus scanner etc and my computer isn't indicating any of the symptoms in the post (I'm also an experience and cautious) user, but you are right - I will run a scan to be safe. – Xtend Jan 20 '12 at 20:09

The OP's issue is indeed very frustrating since I get the same problem. I had to spend quite some time to find a solution. I realized that this only started occuring after I updated my Intel drivers. So, try this it worked for me:

If you are using Intel drivers, please go to Control Panel -> Network and Sharing Center -> Intel PROSet/Wireless tools (on the bottom left).

Then after the tool launches, click on 'Settings'. Ensure that 'Automatically connect to free wifi hotspots' is unchecked.

You do not need to disable your Wifi or change any other settings

  • This is outrageous. Who the hell writes software like that, and how could anybody think I might be ok with this being a default! Thanks for the pointer Munku! – remram Oct 28 '13 at 4:18
  • For me this setting was in the section called 'Intel WiFi HotSpot Assistant'. It is a horrible idea to have software automatically connect to any network. It even connects when I already have an existing broadband connection. – Jorrit Schippers May 19 '14 at 11:42

Roaming Agressiveness was my problem.
I followed the instructions in this PDF and it worked perfectly for Windows 8.

From PDF:

How to Lower Roaming Aggressiveness Using Windows XP

  1. Right-click the wireless icon in the system tray (lower right); select Open Network Connections
  2. Right-click your Wireless Network Connection;
    select Properties
  3. Click the Configure button
  4. Go to the Advanced Properties (depending on your driver or wireless card, this may be on an Advanced tab)
  5. In the Properties field, select Roaming Aggressiveness or Roaming Tendency
  6. In the Value area, select the lowest possible setting
  7. Click OK to save changes

NOTE: If your card does not have this option you may need to update your drivers. Visit the Web site of your computer or wireless card manufacturer for the latest drivers.

You can see a list of available wireless networks, and then connect to one of those networks, no matter where you are. The wireless networks appear only if your computer has a wireless network adapter and driver installed and the adapter is enabled.

If you want Windows to request permission prior to attempting to connect to a wireless access point, you may turn-off Wireless connection on the laptop.

You may have a switch on the laptop to turn-off the same. Turning off wireless is specific to laptop model.

You could follow the links below to configure your preferred networks.

How do I prevent my computer from switching between two preferred networks?

View your preferred wireless networks

How do I prevent my computer from switching between wireless access points?

OR

Auto Enable/Disable Wireless Network Connection In Windows 7, Vista, XP

  • 1
    I guess I may have to disable to adapter but it seems drastic when not that long ago, it wouldn't automatically connect to any network. It was nice when it (by default) wouldn't connect to anything unless I opened the network list and told it which to connect to. – Xtend Jan 20 '12 at 19:59
  • I've also looked at the links but they don't really apply as I have no preferred networks in range when traveling - the articles address connecting to certain preferred networks when one or more is in range. – Xtend Jan 20 '12 at 20:06
  • 2
    @Peter Arandorenko: I found your answer unhelpful. Obviously we can connect to whatever network we want on demand. The original poster reported a change in the behaviour of Windows 7 such that at some point it began automatically connected to previously-unknown, insecure networks. I have experienced exactly the same problem, and I'd love to hear a clear articulation of why it's occurred and how to address. – user157876 Sep 12 '12 at 15:07
  • This answer suggests that using a hardware switch will solve the problem of windows automatically connecting to unsecured networks. I have this same problem but this response clearly does not make any sense. Furthermore, none of the links mentioned actually pertain to the question. – jbbiomed Oct 15 '12 at 8:20

This is a wild guess that's not based on facts.

  1. Check when your wireless drivers were updated last, could be a change in drivers behaviour.
  2. For some software that controls wireless networks it's possible to tell the wireless card to connect to any network by specifying special any or auto as network name. Could you've at some point used wlan that had some kind of special word or wildcard that your system did not escape properly leaving a match to all connection to your wireless AP list.

Are you using the wireless LAN utility supplied by the wireless device manufacturer in addition to the Windows 7 wireless network manager? In my case I registered a wireless network with the Realtek 11n wireless LAN utility (telling it my network key) before I registered that wireless network with the Windows 7 wireless network manager.

The Realtek 11n wireless LAN utility had "connect automatically when this network is in range" set to yes and the equivalent setting in the Windows 7 wireless network manager only pretended to work. So I deleted that wireless network and re registered it firstly with the Windows 7 wireless network manager, it then regained control of the "connect automatically when this network is in range" setting.

You can try the following:

  1. open "Manage Wireless Networks"
  2. go to "Adapter Properties"
  3. click "Configure"
  4. go to "Advanced" tab
  5. change "Roaming Aggressiveness" to a lower setting

Here is what Intel says about the setting: "Wi-Fi roaming aggressiveness refers to the rate that your Wi-Fi client automatically selects and switches to another access point or router with better signal quality."

  • In this context, Wi-Fi roaming refers to switching among access points which have the same SSID and are providing access to the same network (e.g., in a facility large enough that it needs multiple access points to provide coverage). This is a different situation from the one the OP describes. – Mox May 17 '13 at 20:37

Your Answer

 

By clicking "Post Your Answer", you acknowledge that you have read our updated terms of service, privacy policy and cookie policy, and that your continued use of the website is subject to these policies.

Not the answer you're looking for? Browse other questions tagged or ask your own question.