I am trying to install perf. I searched online that it is available through http://apt.ubuntu.com/p/linux-tools, but I need apt. I have yum installed, but do not have apt so I tried installing apt via "yum install apt" but I get this message:

Setting up Install Process
No package apt available.
Nothing to do

Also, I have on my machines Red Hat AS5 and CentOS 5, not Ubuntu. Is installing from that Ubuntu repository okay?


Just type in command line:

yum install perf

(Dont forget sudo if you are not running as admin.)

  • I tried that. Seems like perf isn't found. Here's the message I get: yum install perf Loaded plugins: rhnplugin, security This system is not registered with RHN. RHN support will be disabled. 2010Q4-rhas5-x86_64 | 951 B 00:00 Setting up Install Process No package perf available. Nothing to do – barrrista Jan 20 '12 at 22:35
  • @user1119779 did you try it on centos, I tried it on centos 6.2 and it worked perfectly? The problem might be something else for you, then. However I think the way to go via the apt thing, is not the right thing to do. – inf Jan 20 '12 at 22:47
  • 1
    turns out it isn't available for centOS5. starts with centOS6. going to try to build from source... – barrrista Jan 21 '12 at 1:38

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.