I want to give permissions to a specific user on a remote machine on my local network. In the Select Users or Groups dialog the From This Location field is locked to my computer, when I click the Locations... button the only option in the list is again only my own machine. How can I add a remote computer there so I can select users from other machines?

The remote computer is in my Homegroup, and same Workgroup, generally I don't have problem with file sharing, IP networking, etc. Just need to find a way to get permissions to specific users on that computer.

  • You could create a dedicated user on the remote machine, tell its password to the other users and have them map a drive (net use command) with the credentials you gave them (For a business environment you can also install windows server and set up a domain controller). – BornToCode Feb 4 '16 at 3:32

You can't. Your computer does not have knowledge of the users in the remote system. In order to provide permissions for a specific user, you must create a user on your local computer and give the credentials to the (human) user of the remote system.

The From This Location field is a feature to locate users in another domain or organizational unit and can't be used to select another computer.

  • 1
    But how do I create a user on your local computer and give the credentials to the (human) user of the remote system? – jp2code Nov 18 '12 at 13:01
  • You can add users to your local Windows 7 compter in Control Panel -> User accounts – shufler Nov 19 '12 at 16:08
  • 1
    yes, but the remote machine won't be able to connect as that user you added from control panel, from the exact same reason - it's on a different location so it won't recognize any user not directly on it? Is there any way to connect as a user not in your location? – BornToCode Feb 2 '16 at 21:55
  • 1
    @BornToCode the remote user must use an account that is known to the local computer when connecting to the local computer, i.e. LOCALCOMPUTER\username, not REMOTECOMPUTER\username. – shufler Feb 2 '16 at 23:47
  • Small caveat: don't try to set permissions for password-less users. It won't work even though "Password protected sharing" is turned off. You can, however, set permissions for group Everyone, which will include password-less users. Don't forget to set "Password protected sharing" off. – Chris May 22 '16 at 14:33

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.