Mid 2009 iMac Lion 10.7.2

I've had the most obscure problem lately. I recently screwed over my mac by installing ubuntu, but forgetting to move GRUB. So I had to reinstall firmware and such. It's been working fine EXCEPT for one thing.

Saving. It saves things like documents and such quite easily, but things like the dock, preferences, stuff like that doesn't save. It just so happens my wallpaper is stuck with the trollface saying "problem?" It changes, but when I log back out and in, it is reset.

Also, it won't save documents/files without prompting for an admin pw if it's not within the first 2 levels of my home directory.

I've tried getting the info of my home folder, unlocking it, and saving the permissions for RW for me with all enclosed items. I've also tried repairing perms.

EDIT: it says I don't have permission when I try to copy over a file.


Couple of things to try (in ascending order):

  1. Launch Disk Utility, select your hard disk, and click "Verify Permissions". If you detect any problems, try to repair your disk permissions. Reboot and retry.
  2. I assume you have an Intel Mac (2009 was specified). Try resetting your SMC, as specified in this Apple Support article.
  3. Put Lion on a USB disk, boot from it (hold Option while starting), use Disk Utility to wipe the disk and re-install Lion

Good luck!


I never trust the Finder Get Info window's ability to set file permissions correctly. As a longtime (20+ years) Mac user but someone who knows Unix file permissions well, the restrictions in Finder's Get Info window don't make any sense to me.

You could use the shell to recursively reset all of your home directory files to be owned by you, and to be readable, writable, and executable/traversable by you:

sudo chown -R $(id -u):$(id -g) $HOME
sudo chmod -R 700 $HOME

Beware that this is a bit of a blunt instrument. If you had something in your home directory that needed special permissions, this might screw it up.

It's also worth looking to see if the files you can't overwrite have any file flags or ACLs set on them. You can do that with my favorite file-permission-debugging set of options for ls:

ls -laeO@

In fact, do that in a directory where you can't seem to save files, and see what it says. Also do it on your ~/Library/Preferences/ directory. Update your Answer with the output (or a relevant snippet thereof).

  • It's still saying I don't have perms down in my appdata directory. It doesn't look like there's anything wrong with it, but here's the output: EDIT: Output is too long, and there didn't seem to be anything wrong – Astrognome Jan 24 '12 at 6:39
  • @Astrognome You can update your Answer with the output, rather than trying to leave it as a comment. – Spiff Jan 24 '12 at 17:18

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.