I'm trying to install Lync server 2010 but i'm stuck for a while now with the "Active Directory Preparation" part of the Lync server 2010 installation. The "Prepare Schema" fails with the following error: "Step 1: Prepare Schema Run once per deployment. Extends the schema for Lync Server. Not Available: Failure occurred while attempting to check the schema state. Please ensure Active Directory is reachable."

screenshot: https://skydrive.live.com/#cid=CB15F1A932B364BE&id=CB15F1A932B364BE%211742

The situation: 1 server with Windows Server 2003 (x86), which is the only Domain Controller (DC) 1 server with Windows Server 2008 R2 (x64) where Lync should be installed.

First I have found that the DFL/FFL were not correct:

On the DC (server2003) I have changed the Domain Functional Level to Windows Server 2003 and also the Forest Functional Level to Windows Server 2003. If I check these settings on the Server2008 with Active Directory Domains and Trusts, I see indeed that the DFL and FFL are being set to Windows Server 2003. (Windows Server 2003 is the minimum required for Lync server 2010)

I tried the Lync AD Preparation again but still got the same message: https://skydrive.live.com/#cid=CB15F1A932B364BE&id=CB15F1A932B364BE%211742

I'm logged in on the Server2008 and Server2003 with the domain administrator account. If I check "Active Directory Users and Computers" and go to the directory Users and watch the properties from the Administrator User then it is also a Member of:

  • Domain Admins
  • Domain Users
  • Enterprise Admins
  • Schema Admins
  • Group Policy Creator Owners

The firewall on the server2008 is turned off, still nog working

So now my question is: what should I do to make the Lync setup (Active Directory Preparation) work? (I would appreciate clear step-by-step suggestions to check.)

Thanks in advance.

Update 1: Now I've extended AD successfully on the 2003 DC, using this link: http://blogs.pointbridge.com/Blogs/sloan_jason/Pages/Post.aspx?_ID=2
but when I check the Active Directory Preparation again on the Lync install, it still gives me the same error as in the screenshot I've provided.

Update 2: I found out that there is a log on "C:\Users\\AppData\Local\Temp\ with this:

Get-CSDomainState > Get Domain State
Error: An error occurred: "Microsoft.Rtc.Management.ADConnect.NoSuitableServerFoundException" "No suitable domain controller was found in domain "OurDomain.LOCAL". Errors:\r\n"OurDCserver.OurDomain.LOCAL5.2 (3790)5.2 (3790) Service Pack1OurDCserver.OurDomain.LOCAL5.2 (3790)5.2 (3790)Service Pack 1""

I thought Lync could be installed with a Windows Server 2003 (according to the documentation on technet) and it doesn't require a SP. :s

  • I have this exact error, did you manage to resolve this? – Eric Herlitz Jul 5 '12 at 18:42

To prepare the forest and domain for the installation of the first Windows Server 2008 R2 domain controller please perform these tasks:

Lamer note: The following tasks are required ONLY before adding the first Windows Server 2008 R2 domain controller. If you plan on simply joining a Windows Server 2008 R2 Server to the domain and configuring as a regular member server, none of the following tasks are required.

Another lamer note: Please make sure you read the system requirements for Windows Server 2008 R2. For example, you cannot join a Windows Server 2008 R2 server to a Windows NT 4.0 domain, not can it participate as a domain controller in a mixed domain. If any domain controllers in the forest are running Windows 2000 Server, they must be running Service Pack 4 (SP4).

First, you should review and understand the schema updates and other changes that ADPREP makes as part of the schema management process in Active Directory Domain Services (AD DS). You should test the ADPREP schema updates in a lab environment to ensure that they will not conflict with any applications that run in your environment.

You must make a system state backup for your domain controllers, including the schema master and at least one other domain controller from each domain in the forest (you do have backups, don't you?).

Also, make sure that you can log on to the schema master with an account that has sufficient credentials to run adprep /forestprep. You must be a member of the Schema Admins group, the Enterprise Admins group, and the Domain Admins group of the domain that hosts the schema master, which is, by default, the forest root domain.

Next, insert the Windows Server 2008 R2 DVD media into your DVD drive. Note that if you do not have the media handy, you may use the evaluation version that is available to download from Microsoft's website. You can also use an MSDN or Technet ISO image, if you have a subscription to one of them.



This is most likely a DNS issue. I have found several references to the SRV records not being properly configured. This thread is a fine example: http://social.technet.microsoft.com/Forums/en-US/ocsplanningdeployment/thread/48258bcd-5555-4590-b04b-5d20e8753668

  • I will check the SRV records tomorrow. Never changed/added such SRV records. I'll let you know if that works or not. – juFo Jan 24 '12 at 20:48
  • @juFo Any luck yet? – dwolters Jan 30 '12 at 19:21
  • well I didn't find the DNS problem. – juFo Mar 4 '12 at 10:57
  • @jufo When you say that the DFL and FFL are set to Windows 2003, do you mean native mode or mixed mode? Only native mode is allowed. I was reading through these instructions and noticed this. – dwolters Mar 6 '12 at 16:59
  • I've set up a new DC inorder to fix the problem(s). – juFo Aug 11 '12 at 9:55

I was getting same error but I was successful to resolve this issue. Actually you are login as a local user, Please log in to server as a user which is defined in your active directory server in such a way user@domian.


You haven't logged in as a member of the domain as an admin. As well, make sure you have installed Active Directory Domain Services, and Active Directory Lightweight Directory Services Tools on Active Directory Domain Roles

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.