I'm having this problem only with the wireless network at the company where I work.

First off, I clicked the 'network' icon in the system tray (looks like mobile reception bars), found the company's wireless network in the list, clicked it once, then clicked 'Connect'.

It then prompted me for the security key, which I entered correctly, and it proceeded to connect.

Everything went fine after this and I was able to connect.

However the next day I came in at work I tried to reconnect using the saved settings and it came up a connection error.

I went through the troubleshooting wizard but it was unable to resolve the problem. It displayed this error:

Windows cannot connect hidden wireless network .

So I went to the 'Newtork and Sharing Center' then 'Manage wireless networks' and deleted the entry.

Then I started again from scratch, as above, and this time I was able to connect.

However, this is getting annoying. I don't want to have to keep creating the network from scratch every time I come in to work.

Why can't it connect to the saved network?


After running the troubleshooter,I went into the 'details' bit and noticed that in the 'List of preferred networks', under the company's network, it listed the following setting:

Connect even if network is not broadcasting: No

This seems a bit odd, as, when I check in the properties of the wireless network, the equivalent checkbox is checked.


I'd contact your IT department and explain the problem. They've presumably set up the wireless network to be hidden for a reason. They also need to ensure that employees can connect to the network without jumping through hoops every time.

| improve this answer | |

You could try explaining to your network admins that hiding the ssid is pointless as this site explains


| improve this answer | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.