My bash prompt, which I'll admit to have stolen from a few places and cobbled together, will sometimes add part of previous commands to its length when scrolling the bash history with up/down arrows.

For example, if my previous commands were:

cd /home/caleb
vim .bashrc

When I was at my prompt and scrolled up twice it might look like:

$ vim .bcd /home/caleb

Where the first five characters are left over from last command.

Does anyone have any idea why this is happening, and how it can be stopped?

My prompt is set with this code (way to long to include here): https://gist.github.com/1679352

  • 1
    Set PS1 to a value without the whole vcs crap and see what happens. That's my guess.
    – Daniel Beck
    Jan 26, 2012 at 0:44
  • Have you already found the culprit in your prompt? I'm having the same issue.
    – acme
    Jul 10, 2014 at 8:58
  • Yeah bash loses it on colors, and is unable to separate the length of strings with color escapes from the length of the visible string. This is what SiegeX was getting at. I ended up switching to ZSH and using a different prompt. ZSH doesn't have the same issue. Jul 11, 2014 at 13:45
  • 2
    Both previous answer didn't get my problem solved, and did not give any explaination why this happened. Please check Custom Bash prompt is overwriting itself, if anyone have search to this point.
    – D3Hunter
    Dec 22, 2014 at 3:05
  • Related issue unix.stackexchange.com/questions/105958/…
    – matthiasbe
    Jun 27, 2019 at 14:21

6 Answers 6


Somewhere your prompt is fubar. What usually happens is that your shell thinks its outputting non-printable term codes and expecting it to take up space. The best advice I can give you is to systematically add to (or take away from) your prompt until this behavior stops to isolate the code that is causing this issue.


The color codes need to be wrapped in square brackets. The brackets inform bash that the enclosed text should not be printed

building on @Phreditor's example, this shows that any formatting done after the newline will result in the original issue:

export PS1="\n\n\[\033[01;33m[\w]\033[00m\n\033[0;90m\$ "

wrapping the format code in [] ensures that annoying behavior never happens:

export PS1="\n\[\[\033[01;33m\][\w]\[\033[00m\]\n\[\033[0;90m\]\$ "

The documentation: http://tldp.org/HOWTO/Bash-Prompt-HOWTO/nonprintingchars.html

Since PS1 formatting causes the value to be so long and hard to read I put the format codes in variables:

export PS1="\n${BYELLOW}[\w]${PS_CLEAR}\n${IBLACK}\$ "
  • 4
    This should be the accepted answer. Did solve the issue.
    – Atcold
    Oct 26, 2017 at 0:50
  • 2
    It should be noted (because I failed to note it ;) ), that in that mess of backslashes and square brackets, the square brackets that follow the escape sequence \033 should NOT be escaped. Only the wrapping square brackets are to be escaped.
    – Benjam
    Jan 31, 2018 at 16:29
  • 1
    Way to confusing for me to deal with all those special characters, using the first google result helped generate a working prompt exactly how I wanted it: ezprompt.net
    – Mallox
    Jun 26, 2018 at 19:26
  • I have been wanting to customize my prompt colors for YEARS but never have since I always had this issue! I could never figure out why so I just stopped and kept everything white... I was just setting up a new computer and it finally dawned on me to actually Google the issue for once... So glad I did! Thank you for this wonderful lesson.
    – TylerH4
    Jun 13, 2019 at 17:20
  • I cannot even begin to explain the amount of pointless frustration this issue has been giving me. Thank you kindly, sir. Apr 4, 2020 at 22:06

I had the same problem and it was related to the color definitions.

In my case, I have a multi-line prompt (gives most space for current command regardless of path length displayed by prompt).

Bad version:

export PS1="\n\n\[\033[01;33m[\w]\n\033[00m\$ "

Good version:

export PS1="\n\n\[\033[01;33m[\w]\033[00m\n\$ "

\033[00m terminates the color. If it is after the new line (\n), it prevents proper redraw in the terminal, to overwrite previous commands with background color. Moving it behind the new line resolved the problem.

(using Terminal in Mac OS 10.8)

  • This pinpointed the issue for me, while the current accepted answer was too generic.
    – notbrain
    Dec 20, 2014 at 17:38
  • This is the more precise answer and should be the winner (and was the solution to my problem as well). Apr 24, 2015 at 15:49
  • the \n were the culprit for me too. Thanks!
    – mhulse
    Mar 12, 2016 at 9:05

I actually think this has to do with a missing 'non-printing character' delimiter. I had exactly the same issue, but moving it before the newline (\n) didn't fix it. Instead I correctly surrounded all non-printing characters (here, colouring commands) with '\[' and '\]'.

Bad (works, but has the history-mashing problem described above):

PS1="\e[32m\u\e[35m@\e[32m\h \e[33m\w\e[36m\n\$\e[0m"

Good (surrounded all colour commands with '\[' and '\]' - does not show mashed command history):

PS1="\[\e[32m\]\u\[\e[35m\]@\[\e[32m\]\h \[\e[33m\]\w\[\e[36m\]\n\$\[\e[0m\]"

i.e. "\e[...m" --becomes--> "\[\e[...m\]"

And if you are putting this into something like SecureCRT to auto-send upon login to a system, you may have to double escape everything (put double backslashes everywhere) if auto-login system consumes the first backslash itself to determine the character to be sent:

PS1="\\[\\e[32m\\]\\u\\[\\e[35m\\]@\\[\\e[32m\\]\\h \\[\\e[33m\\]\\w\\[\\e[36m\\]\\n\\$\\[\\e[0m\\]"

i.e. "\..." --becomes--> "\\..."

(This is definitely true of SecureCRT and may be true of others, such as PuTTY or TeraTerm - testing required on your part.)


I was with this issue. What i detected?

When you have colors inside PS1 variable (ex: "\e[35m" ) it ALWAYS have to be surrounded by "\[" and "\]" (ex: "\[\e[35m\]" ).

When i marked all colours in PS1 according to this rule, it worked!

No more problems with scrolling the history of bash.

BAD EXAMPLE: PS1="\e[0;36m[\u@\h[\e[1;31m$ORACLESID\e[0;36m] \W]\e[0m"; export PS1

GOOD EXAMPLE: PS1="\[\e[0;36m\][\u@\h[\[\e[1;31m\]$ORACLESID\[\e[0;36m\]]\W]\[\e[0m\] "; export PS1


Building upon others answers, most likely there's some line in your .zshrc or .zshenv or somewhere else you edited is messing up your command line because it has the wrong syntax, usually a good place to start looking for the source of the issue is anything related to colors. For me it was this line:

PROMPT="$fg[blue]%}myhostrname ${PROMPT}"

When I properly wrapped $fg[blue] inside %{$fg[blue]%} like so:

PROMPT="%{$fg[blue]%}myhostrname ${PROMPT}"

It was fixed.

Context: Zsh theme I was using didn't display the host's name on the terminal so I hardcoded it via this command, but I missed up the color's syntax which caused the command line to freak out with unexpected behavior on several occasions. Been like that for a year or so and I only finally decided to fix it lol.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.