For quite some time now, I experience a weird behavior of Notepad++. I associated .xml files to Notepad++. For most of the time opening .xml files works fine. Sometimes though, the file won't open if I drop it into Notepad++ or try to open in with double click. The only way I can access it is through the open-file dialog.

I observed this in the beginning from certain network storage locations. Today I had it on my local disk also. I didn't see any settings in notepad++ that gave any indication that they might influence this.

Does anyone know what is the reason for this and also how I can "fix" this?

(Btw: It's not only xml files it seems, but I verified that it happens there!)

  • I'm seeing this too on Server 2012 R2, on just my account (member of Administrators), and on a filesystem folder which is also a share. I don't know the cause but the potentially useful additional info I have is that a) if in folder properties I click Security\Advanced\Effective Permissions and enter my username it says Access Limited By: Share b) turning the share off fixes right click Open in notepad++. – Stephen Kennedy Sep 22 '14 at 19:20
  • A later version of NPP doesn't have this problem any more (at least on my computer). Now I'm unsure if it is really related to new version or if something else changed. – StampedeXV May 26 '15 at 13:49
  1. Update your Notepad++ to latest version.

  2. Go to the installation folder of Notepad++, e.g c:/program files(x86)/notepad++ or wherever you installed it. Then right click the Notepad++ exe file, choose properties. On properties dialog go to 'compatibility' tab, to the bottom check the check box labeled "Run this program as administrator" and click OK.

This should resolve your problem.

  • So if you hacked the latest notepad++ version I just gave you admin rights on my computer ;) – StampedeXV Jan 26 '12 at 12:25
  • @StampedeXV: Nah, that perception can't be correct because every other program which by default can open all those files, they by default have those rights, but there are few which don't have them by default, so they are not able to function normal. But we given the rights they will now able to open and run/edit files when we need. Plus if you are conscious about security, it must probably done by those antivirus/firewall software. – K. Shahzad Feb 22 '12 at 8:51
  • It really worked for some locations, but still not everywhere. – StampedeXV Aug 16 '12 at 8:47

I had the same issue but for me checking the "Run this program as administrator" did not work. So from the same compatibility tab, I checked instead "Run this program in compatibility mode for:" and selected "Windows XP (Service Pack 3)" This did the trick for me

  • Telling someone to run a text editor as administrator is TERRIBLE advice. – kreemoweet Apr 4 '12 at 16:31
  • In general you are right. But if you know you are running it as Admin, you can take precautions and be very careful. The alternative to always go through open-file dialog is not an alternative. I'll try sam's advice. – StampedeXV Apr 12 '12 at 13:59
  • On Windows 10, "Run this program in compatibility mode" alone was enough, I did not need "Run this program as administrator" at all. – Juuso Ohtonen Oct 19 '15 at 5:42

I went to C:\Program Files (x86)\Notepad++\plugins and found the LightExplorer.dll plugin in the root directory there. Copied and moved it to a backup location, killed all Notepad++ processes in Windows Task Manager before I deleted the file. The program started up fine once again after the operation.

Regards, Pradeep KR

  • I got a new computer and installed everything again. Now I don't have this problem any more. Don't know the reason, but maybe Notepad++ installation is done differently now? – StampedeXV Apr 4 '13 at 7:28

My problem was I couldn't on click open any file by note++ (version6.6.8). Not any of the above ways worked for me. I tried to solve this problem in several ways and find this solution.

  1. I deleted all files of previous version.
  2. Scan for registry issue by CCleaner.
  3. Found some issues regarding note++ and fixed by CCleaner.
  4. Right click the file I want to open, choose default program as note++ and that's all.

For Windows8

There is similar problem and workaround trick for latest Notepad++ 6.5.5.

  1. Right click on file: C:\Program Files (x86)\Notepad++\nppIExplorerShell.exe
  2. Select compatibility tab.
  3. Set program to run in Windows XP SP3 compatibility mode.

You wont need any permission or compatibility modifications on main program file, it should work just fine after you have changed nppIExplorerShell.exe compatibility mode.

It also does not require Administrator privileges.

Note: For me, setting main program to run as Administrator did not change anything. Even while using Notepad++ with elevated permissions it did not even display network drives in Open file... dialog. Also it did not open any files from network drive when launched from Explorers file context menu.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.