My Windows XP (SP3) machine (at work) occasionally "forgets" how to cut-and-paste files in Explorer - if I cut or copy a file then go to paste it elsewhere, the "paste" and "paste shortcut" menu items are greyed out.

The keyboard shortcuts (Ctrl+X/Ctrl+C,Ctrl+V) don't work either, and neither does Drag-and-Drop - clicking and dragging a file/folder doesn't change the pointer and letting go doesn't drop the item anywhere.

Restarting the explorer.exe process usually fixes the problem, but sometimes I need to do a full reboot.

Note: this may be related to the following existing question, although that's Vista and it sounds like the asker has more permanent problems than I do:

Copy & Paste in Vista / Explorer broken (not MS-VPC)

So, any idea what might be causing the problem and how to avoid it?


2 Answers 2


When the MSBlaster virus hit us in '03, I remembered there was a flood of calls from clients and friends who had the same problem.

Microsoft's Malicious Software Removal Tool is able to remove Blaster, and they have issued security updates to counter the virus's effects.

Have you tried running some malware removal tool yet?

P.S just remembered something... and it's bad news. Most of them gave up fighting that worm and chose to re-install. I hope you have better luck.

  • Maybe it's not actually a virus or worm...
    – alex
    Sep 9, 2009 at 11:02
  • @alex : I sincerely hope for ezwi that my answer is wrong, and it is actually not a virus or worm.
    – caliban
    Sep 9, 2009 at 11:19
  • @scoopdreams - I think you mean for me. Anyway, my VCheck runs without detecting anything every Friday afternoon, plus this isn't an ALWAYS thing. The machine runs fine and then "suddenly" forgets how to copy-and-paste. Of course, the real truth is something's screwing with it. Just wondered with anyone out in Super User land knew any possible culprits. Sep 9, 2009 at 12:42
  • Tried the services yet? Network, Network DDE, Clipbook - these 3 services are essential to normal copy functions. Though if an explorer restart solves the issue, i highly doubt this is the problem.
    – caliban
    Sep 9, 2009 at 12:52

Try re-registering the shell .dll:

  1. Click Start
  2. Click Run
  3. Type regsvr32 /i shell32.dll and hit OK
  4. Restart

Good quick fix if it works.

  • As suspected, re-registering the shell didn't work :-( Apr 7, 2010 at 8:14

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .