23

Since upgrading from Firefox 3.6.x, my address bar has a quirk that never used to be there. When I type in, for example:

localhost/my_dir/index.php

Firefox turns it into a search query, my search engine is Google. To work around this (after forgetting I need to do this almost every time for FF), I must type in:

http://localhost/my_dir/index.php

This way, I am directed correctly to my localhost server. I don't need to do this for any other browser, and I thought this Q/A on URL trimming might change the behaviour, but it didn't.

Any ideas on how I can prevent 'localhost' from being turned into a search query?

23
  1. Type about:config in the URL bar
  2. In the filter search box, type browser.fixup.alternate.suffix
  3. Double click this entry to edit it and remove: .com

Now your localhost files should work without having to add http://.

  • 1
    This doesnt work for me! I've restarted Firefox and entering "localhost:4567" does a google search! – IanVaughan Feb 21 '12 at 11:35
  • 14
    I do not think this is the correct answer to this question, as it rather prevents FF appending .com to anything you type into the address bar. However, this works fine. For the sake of completeness: I found this setting better to use: browser.fixup.alternate.enabled, as above solution still prepended .www (there's a separete setting for this (called browser.fixup.alternate.prefix). – peterp Jan 22 '13 at 10:03
  • 2
    @IanVaughan With regard to the question, I consider this to be the correct answer, since it actually is about search queries: superuser.com/questions/382905/… – peterp Jan 22 '13 at 10:04
7
  1. In the Location bar, type about:config and press Enter.

  2. The about:config "This might void your warranty!" warning page may appear. Click I'll be careful, I promise!, to continue to the about:config page.

  3. In the Search field, type keyword.enabled.Double-click the keyword.enabled preference to set its value to false.

Please note that this will also prevent things that aren't URL-like from being used as search terms. For example, after making this change, if you type "how to tell if an egg is boiled" in the search bar, you'll just get a DNS error.

Other answers on this page give a way to attempt your suffix-less server name without modification (let's say you have a server in your domain called git, when you type just git/ and there is a DNS problem, instead of navigating to www.git.com you'll just get a DNS error page).

solution from Mozilla

3

I know this is kind of a weird solution, but you could map localhost.com to 127.0.0.1 with your %windir%\system32\drivers\etc\hosts file.

Start notepad as administrator (by using the context menu on-top of it in the Start menu) and open the file %windir%\system32\drivers\etc\hosts, then add an entry like this:

127.0.0.1 localhost.com

to the end of the file. Save. Now you should be able to use localhost.com in place of localhost, which Firefox shouldn't complain about. Note that this works for practically any domain name you want, so you can make it shorter.

  • I've been using this method since I discovered it a couple of weeks ago. I use local.host. This is a much simpler solution than configuring the search engines in the browser. :) – iglvzx Jan 27 '12 at 3:00
  • Hmm... my hosts file already has "127.0.0.1 localhost" in it, I added the new entry, saved as admin - checked, restarted Firefox... same behaviour. @iglvzx: Do you literally type in "local.host/xyz" to the address bar after adding that to hosts? – danjah Jan 27 '12 at 3:28
  • @Danjah Yes, that's what I do. What did you add to your host file? – iglvzx Jan 27 '12 at 3:33
  • I added another line, under "127.0.0.1 localhost", "127.0.0.1 localhost.com", is that correct? – danjah Jan 27 '12 at 4:49
  • 1
    This will work in all of your browsers, and additionally you can make it shorter (e.g. l.h should work even.) – John Chadwick Jan 27 '12 at 5:24
3

After trying the solutions already posted the problem was still occurring in my environment. A Google search directed to https://cdivilly.wordpress.com/2013/08/15/disable-firefox-redirecting-to-localhost-com/

This blog post suggested changing the browser.fixup.alternate.enabled property to false. This did the trick for me.

  • 1
    This solved it for me as well. Thanks, @axiopisty! – Asbjørn Ulsberg May 9 '16 at 19:41
1

To avoid this problem, I configured Firefox to always show the http:// protocol in URL bar.

In about:config, set browser.urlbar.trimURLs to false (https://support.mozilla.org/en-US/questions/881261).

0

As said here:

  1. Type about:config in the URL bar,
  2. Create boolean parameter browser.fixup.domainwhitelist.domain_name (replace domain_name with your local domain name, like localhost),
  3. Set new parameter's value to true.
0

If you still want to be able to search from the address bar, but you also want to be able to open local URLs, you can set the about:config property browser.fixup.dns_first_for_single_words to true, which will do a DNS query for single words like localhost or myserver and only turn it into a search if the DNS query fails.

This gives you the best of both worlds - you can still search from the address bar, but if you put in the name of a machine on your LAN, then you'll just connect to that instead (assuming your DNS or hosts file is set up correctly of course!)

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.