I have both Google Chrome and Eclipse pinned to my taskbar in Windows 7 64-Bit. However, when I launch these programs, they don't appear to open under the pinned taskbar icon

Launching a chrome window looks like this

Eclipse behaves similarly. The Eclipse launcher/workspace selector is under the pinned icon, but once the IDE opens, it moves from the pinned icon, to a new group at the end of the taskbar.

Unpinning/repinning doesn't seem to do the trick. It's bothersome to have taskbar space wasted on both the launcher icon, and the window button.

Anybody have an idea how to get normal behavior out of the taskbar?

  • 1
    This usually happens when you run a program with different command-line options (the taskbar-pinning algorithm sees them as different programs). Perhaps you pinned an instance of Chrome that you ran with a switch and now use the normal shortcut. Alternately, maybe you pinned the normal program and then modified the shortcut.
    – Synetech
    Commented Jul 8, 2012 at 16:15

5 Answers 5


The problem is that the pinned application actually starts another process (which is not pinned). This often happens with applications that spawn a 64bit version of itself after they were started.

Sometimes it helps to unpin the application you have on your task bar, right-click the new task and select "Pin this program to task bar".

FYI: There's a bug report for Chrome on exactly this issue. When I looked into this issue myself a couple of months ago, it seemed like it is generally an application issue (not a general Windows issue). So for every application I use that has this problem, there are usually bug reports about it (FileZilla, Eclipse, ...).

  • 1
    As i said in the question, unpinning, and repinning the new task doesn't seem to do the trick, but that seems like a sensible explanation of why it's happening.
    – Chris Bye
    Commented Jan 27, 2012 at 15:52
  • Plus, I have not seen this happen with Chrome on a 64-bit system. Further, I have not seen it spawn another process, so something else may be happening if some people are seeing Chrome spawn a child process.
    – Synetech
    Commented Jul 8, 2012 at 16:13
  • chrome spawns a new process for (at least) every tab. And does chrome even have a 64-bit version yet?
    – Luke
    Commented Jun 6, 2013 at 0:58
  • @Luke: Correct, Chrome does spawn a new process for new tabs. But those processes are child processes and the parent doesn't exit until you close the main application. This behavior is unrelated to the question though. How Chrome having a 64bit version or not is a relevant question in this context is unclear to me as well. Commented Jun 6, 2013 at 20:39
  • Because @Synetech implied Chrome spawning a child process was an uncommon occurrence, and you indicated that 64 bit versions of programs can often cause this (which can't be the case if we're talking about Chrome on Windows as there is no 64 bit version).
    – Luke
    Commented Jun 7, 2013 at 0:54

To solve this issue do the following:

  1. Start Google Chrome (this creates a new taskbar icon);
  2. Right click on the new icon and select "Pin this program to taskbar";
  3. Go to: %APPDATA%\Roaming\Microsoft\Internet Explorer\Quick Launch\User Pinned\TaskBar;
  4. You will see the two pinned Google Chrome.lnk here. Delete the Google Chrome.lnk and make Google Chrome (1).lnk readonly (Right Click -> Properties -> General tab -> tick Read-only -> Click OK);
  • 1
    Solved the issue for me. A fifth step for me was to un-pin the old icon (assuming you spawned the new icon from an already-pinned one).
    – Kenan
    Commented Jul 27, 2012 at 12:50
  • But it's still feels like bouncing between 2 unrelated instances of Chrome. E.g.: I close Chrome with some tabs open. Some other application tries to open Chrome, it opens the homepage. I close the window and open Chrome using the pinned icon. I get the tabs back. Commented Aug 20, 2012 at 5:33
  • In effect, 2 installations of Chrome. Also, when I search for Chrome, there are 2 entries: Google Chrome (1) and chrome :( Commented Aug 20, 2012 at 5:34

From the Chrome bug reports that I've found working in 19.x is to remove the User Data folder from


When you restart Chrome and pin it, Chrome will then behave and report multiple windows opened under the pinned icon once again.

  • 1
    +1, this is the solution from the bug report mentioned by Oliver and it worked for me. Commented Jun 26, 2012 at 14:27
  • 2
    So the solution is deleting your user data? Oh GREAT!!! ¬¬ Commented Mar 19, 2013 at 13:40
  • This should be the correct answer. Steps to do this without losing all your data: 1) Move (or make a copy and delete) current User Data folder to somewhere else (like your My Documents folder). 2) Start Chrome from the pinned icon. 3) Copy files with data you need (e.g. Bookmarks) from the old User Data/Profile1 (or whatever) folder to the new User Data/Default folder. Commented Aug 15, 2013 at 16:35

There's a solution listed on the Chromium issues site that seems to be "correct" fix. (Note that the issue asked here has been filed as Bug 91650). It looks like the root cause is that Chrome thinks you have more than one profiles, and you are not using the "Default" profile. The fix is to modify a file in the Chrome directory and remove references to any other profile.

  • This was it. The reason I had more than one profile is because I signed in to Chrome with the wrong account, then signed out and signed in with the correct one. This breaks the "pin" feature. The linked solution fixes it.
    – RomanSt
    Commented Sep 17, 2013 at 23:44

Another solution is to try the 7 Taskbar Tweaker.

It will allow user defined application grouping.


You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .