I have a Windows 7 PC. When I right click on an icon, it takes 10 seconds for the menu bar to show.

Here is what eventually appears:

Right click Menu

Why does it take so long? Or any ideas on a systematic way to troubleshoot?

  • 1
    Interesting, I suffer from the same problem and never ask why occurs. I hope someone knows how to fix it. – mjsr Jan 29 '12 at 19:23
  • 6
    Have you compared to a system that doesn't have that many extra loaded shell extensions/context submenus? It looks like a browser loaded with toolbars – random Jan 29 '12 at 19:25
  • Especially all the Adobe stuff. – ZippyV Jan 29 '12 at 19:30
  • 1
    ^ agree with random, same thing with XP some of the items added to the context menu would slow the show, usually it was related to one that did a lot more than just link-to. You could use AUTORUNS to disable them one at a time, and see which one is causing it most. be sure to write-back and tell which one it was. also nirsoft.net/utils/shexview.html might be easier to navigate. – Psycogeek Jan 29 '12 at 19:42
  • 2
    ShellExView is not really user-friendly (definitely not for novices). It is safer and easier just to open each related app and look in the Options/Settings for an item related to integration / (context) menu / handler / shell-extension / etc. and turn that off (make sure to reboot). But disable one at a time and test to see if the delay still happens. Otherwise you won’t know which one was causing the problem and will have disabled the others for nothing. – Synetech Jan 29 '12 at 20:04

You will certainly get better experience when you keep on a clean context menu, what you need to troubleshoot is autoruns from Microsoft.

enter image description here

usage is simple : Browse to the Explorer Tab and uncheck every extra extension you are not using (I doubt if you are using any from there :) and especially the Abobe stuffs.

you can get them back later if you need some.

  • 2
    Thanks a lot! Autoruns is a really handy tool. Taking out "GrooveShell Extension" from the list apparently did the trick and speeded up the menu. – David Faux Feb 2 '12 at 18:23
  • Great. Just add a simple note: Instead of rebooting you can restart the explorer process (by task manager). Useful for server machine (which has slow reboot time) – Hoàng Long Jul 28 '16 at 3:11

It could be that Dropbox is requesting something from the internet every time you right-click and doesn't respond (to display the context menu) until a response is received.

Try disconnecting your pc from the network (or disable/close Dropbox) and see if there is any difference in the behavior.

  • Thanks. I tried turning off ethernet and closing Dropbox. I don't think there's a huge difference. It still takes a long while. – David Faux Jan 29 '12 at 19:35
  • @David, that won’t help. If the DropBox context-menu handler (the piece of code that displays the submenu) does indeed try to access the Internet and/or the files/folders, then it does not matter what you do to the DropBox client program or your Internet connection, the handler will still do its thing. What you need to do is to check the settings in DropBox to see if there is anything related to integration / (context) menu / handler / shell-extension / etc. You can also narrow it down to DropBox by disabling the handler altogether (and reboot) to see if it still happens. – Synetech Jan 29 '12 at 20:01
  • How about Adobe Bridge, does that application do something over the network? – ZippyV Jan 29 '12 at 20:18
  • @Synetechinc. If the handler still tries to make a network connection shouldn't it time out faster without a network available? – ZippyV Jan 29 '12 at 21:02
  • 2
    You would think, but network connectivity has numerous factors, many of which do not give a nice, quick error, but rather cause all kinds of time-out delays (in fact, in a lot of cases, not having a connection increases time where a connection would return the expected data quickly). Of course, not knowing what the specific problem is (or how the DropBox handler works), the most I can do about this issue is speculate. David will have to test himself. – Synetech Jan 29 '12 at 22:40

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.