12

I use VMWare workstation and have had no problems with my virtual machines and bridging the network card. However, I installed Virtualbox to check it out and ever since I can't establish a network connection with my virtual machine network cards being set as "bridge".

I did find I could set them to NAT and get a network connection with the nic card.

Obviously, a possible answer would be to uninstall VirtualBox, but maybe I don't have too, and there is an answer.

I have tried unsuccessful the following to get bridging to work...

  • Uninstalling / Re-installing VMWare tools

  • Uninstalling / rebooting / re-installing network card

  • I have even tried giving nic card static IP and related DNS/Gateway server

Has anyone else experienced this problem or know a solution other than removing VirtualBox?

18

I had this issue also. I figured out that VMBox installes it's own network driver or something like that. When VMWare tries to bridge the network it makes automatic choice.. Obviously wrong. So you have to manually specify which driver it has to load.

I'm using VMWare Workstation.. Thus you go to View->Virtual Network Editor, the first interface in a list would be VMnet0 bridged. You'll see "Brigged to" list below which should be set to Automatic. Switch it to your physical card, not VMBox net adapter..

Then restart you VM, or type "service network restart" in terminal..

| improve this answer | |
  • 1
    you're my savior – armel Jul 13 '12 at 11:07
  • 1
    Just a quick fyi, in VMWorkstation 9, the Virtual Network Editor is located in the Edit menu. – JoshP Jun 19 '13 at 12:16
  • Another way to fix this is disable the vmware bridge protocol for the vbox network adapter using the Network and Sharing Center. – wimh Jun 16 '14 at 7:53
  • Awesome, such a simple fix. I can confirm that both VMWare and VirtualBox play nice with each other after setting the proper adapter. – Mahn Jul 15 '16 at 0:41

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.