8

How can I make VMware player run the VM in full screen in windows? I'm using VMware Player 4.0.2.

  • 4
    @wizlog please don't edit questions in such a way that you change the original meaning. The user had asked how to put it into fullscreen, and you changed it to say maximized, which led to some answers below that misinterpreted that. – nhinkle Jan 31 '12 at 2:36
  • @user Apologies, I (mistakenly) thought the only difference was the word choice, not the meaning of the question. – wizlog Jan 31 '12 at 17:48
  • 1
    @nhinkle Now I realize how easy it is to change the meaning of the question, and will be more careful going forward. – wizlog Jan 31 '12 at 17:48
16

You can use the maximize button on the top right hand side of the window:

enter image description here

You'll also need VMWare Tools installed on the guest in order to have the VM resize the desktop accordingly.

  • that doesn't make it fullscreen & it only makes use of half of screen & the rest area is just black.. – Rajat Gupta Jan 30 '12 at 7:15
  • 6
    @user It works on my machine. Are you sure you have VMWare Tools installed on the VM? – Nils Magne Lunde Jan 30 '12 at 7:24
9

You can use Ctrl-Alt-Enter shortcut. If you have vmware tools in guest installed it will change screen resolution to match one of host.

  • If only it did... mine used to do that, after installing and then removing VMWare tools it's stuck in a resolution and refuses to fullscreen / maximise or anything else. – Owl Sep 10 '18 at 15:07
1

I just had the same problem as you did. Here is my solution:

I installed Ubuntu in the VMware player. You just right click, and click "Change Desktop Background", and click "all setting" at upper left corner. Click "Displays" and change the resolution to 2560 by 1600.

Hope this solves your problem. Thanks

  • Does this work if Windows (or any other OS) is installed on the VM? Does the resolution have to be 2560x1600, or can it be the max resolution of the monitor? – Cfinley Jun 16 '15 at 20:17
0

If the above does not work (my VMWare Workstation 12 does not have this under "change desktop background"), try Display (either on desktop or in menu)

VMWare menu: System/Preferences/Display

change Resolution to 1280 x 800 or more, hit Apply, Keep, Close enter image description here

enter image description here

  • I don't have any of these menus :/ – Owl Sep 10 '18 at 15:09
0

I had the same issue trying to play a Windows XP virtual machine on Windows 10. I somewhat solved it by going to the control panel, then display, then changing the settings. I'm using 1440x900 which shows a little black on the sides and requires me to scroll down to see the bottom, but it's better than looking at a very small VM screen.

-1

It works by changing resolution of monitor. Keep monitor resolution as your system configuration

  • 1
    What works by changing monitor resolution? What do you mean by "keep monitor resolution as your system configuration"? How is this a solution to the question? – fixer1234 Jun 10 '16 at 6:04
  • Welcome to Super User. Please be aware you have posted an answer to a question that is very old and has an accepted answer. Although there is nothing wrong with doing so, just be aware you may not get a response. – CharlieRB Jun 10 '16 at 13:30
-1

I just had the same problem as you did. Here is my solution:

  1. Edit>Preferences
  2. Click "display" on left menu
  3. in the middle part, select "stretch guest"
  4. return to your virtual OS and click on "Full-Screen"

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.