1

Is it possible to get of the (~3s) delay one gets when typing a bad command in Fedora 16? My friend keeps changing the key map but the delay is even more annoying.

5
  • 2
    "My friend keeps changing the keymap but the delay is even more annoying." - How is this related to the question?
    – Michael K
    Jan 30 '12 at 15:39
  • 1
    If you are talking about bash shell commands, there isn't normally any delay after entering a command that bash doesn't recognise. Can you give an example of a command, an error message and indicate exactly when the delay occurs? Jan 30 '12 at 15:40
  • 'bash: sl: command not found...' Followed by a 3s delay. Seems to be fedora specific.
    – tommyo
    Jan 30 '12 at 17:07
  • Michael K: How is this relevant to the question?
    – tommyo
    Feb 6 '12 at 13:51
  • I has the same problem on EVERY fedora 17 installation I tried (which is like ~30, with like 6 different configuration thought) and Paul's answer solved it.
    – fstamour
    Mar 21 '13 at 2:27
2

This is most likely the bash command not found handler. If you check /etc/bashrc or whereever the global bash config file for your distribution is, you should see something like

command_not_found_handle() {

   # what to do
}

This may be included into bashrc from external source.

You can prevent this behaviour by unsetting the function in your ~/.bashrc (or just commenting out the function in the global script):

 unset -f command_not_found_handle
1

In Fedora 16, this extremely annoying feature is enabled by PackageKit.sh. You can disable it, (as root), by renaming the offending script so that it doesn't have a .sh extension. For example:

mv /etc/profile.d/PackageKit.sh /etc/profile.d/PackageKit.sh.disabled

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.