My laptop was getting sluggish, to the point of being unusable. Nearly locked up entirely. I could barely get Task Manager to open, and when it finally did, it showed no applications running, and no processes with high CPU or Memory Usage. I tried to open (SysInternals) Process Explorer, but it said there were insufficient resources to start. So I returned to Task Manager and clicked "Show processes from all users". That revealed a svchost.exe with ~400MB of memory load (but low CPU). I r-clicked and selected "Go to Service(s)", and found that the culprit appeared to be PML HP712. This appears to be related to the HP PhotoSmart software that I installed recently (a hugely bloated monstrosity, I might add). I stopped the service (and set it to Manual), but the memory footprint of the corresponding svchost.exe didn't diminish. I tried to stop svchost from taskmanager, but was unsuccessful "Access is denied". So I have two questions:

  1. Why can't I stop svchost from TM? Is it an Admin Privs issue? If so, how do I run Task Manager with Administrative Privileges? (Actually, my account on the box already has admin privs, so is there another reason I can't stop svchost?)
  2. Can anyone tell me what functionality I would forfeit by permanently disabling PML HPZ12?

UPDATE: Well, the svchost memory footprint finally shrunk back to normal size. So question #1 is no longer as critical (though I'd still like to know).

2 Answers 2


Seems to be an old issue dating back to 2009, I suggest you go to the HP site and download the latest driver for your HP printer

  • Yes, I had seen much other traffic on the issue stretching back even to 2003 (which amazes me that HP can't resolve such pernicious bugs), but it is a brand new printer, so the driver can't be that out of date. (I'll check). Also, the driver was, as I said, monstrous. So it would be quite an undertaking that I'd certainly prefer to avoid, if possible.
    – kmote
    Jan 30, 2012 at 18:33
  • 2
    Just because its brand new does not mean the cd that came with it installed the correct version. Install the version on the website.
    – Ramhound
    Jan 30, 2012 at 20:20
  • I just confirmed that the printer has the most current driver installed.
    – kmote
    Jan 30, 2012 at 21:54
  • I wonder if your security software is interfering with it loading properly, that was one cause in that old 2009 link I posted.
    – Moab
    Jan 30, 2012 at 22:52

My understanding is this: On Windows, even users with admin priviledges are not all-powerful. Processes and services which the system deems critical can not be stopped by any user that is not part of the system itself. In TM, these are listed as owned by "SYSTEM".

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .