I am trying to make Google Chrome the default program for opening PDF files on a Windows 7 PC. I right click the PDF and choose 'Open With'. Chrome is not listed, so I browse to its location (C:\Users\MyName\AppData\Local\Google\Chrome\Application\chrome.exe) and click Open. Nothing happens.

This used to work, so what's changed?

  • have you installed any pdf viewer ? – john Jan 31 '12 at 11:16
  • about:plugins shows that Chrome PDF Viewer is installed and enabled. And if I drag a PDF file from Explorer into Chrome it does open up. – Charles Anderson Jan 31 '12 at 11:28

Fixed it. Chrome had somehow got itself partially uninstalled: it wasn't auto-updating anymore, and when I tried to uninstall it from the Control Panel, I was told it had already gone (though it was listed). I've just reinstalled, and it now shows up in the Open With dialog's list of programs again.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.