I've been trying for a couple days now to install Update for Microsoft Visual Studio 2010 Service Pack 1 (KB2635973) and continue to get this error enter image description here

I even tried a manual download & install and get the same error. Has anyone else had this issue and if so how did you resolve it?

  • Make sure you run also this update from a Administrator account. Not a standard user with admin privileges but a Admin Account. Try out if that might be a problem. – Devid May 31 '14 at 20:07

I had an issue once where a certain configuration of Microsoft .NET programs wouldn't let me install something similar, with the same generic error code 643. I ended up formatting the computer (because of my own stupidness at the time) and re-installing again.

But this is a known issue and has a Knowledge Base Article


Taken straight from that article:

To resolve this problem, you must fix the MSI software update registration corruption issues, or uninstall multiple versions of the .NET Framework by using the .NET Framework Cleanup Tool, and then reinstall those components.

The article then walks through the two methods above. Hope this helps!


As with many errors with Microsoft Update failing to install a patch, try downloading the patch and manually installing it.

You can get the patch here.

Make sure you run the patch with Administrator privileges.

Your Answer

By clicking "Post Your Answer", you acknowledge that you have read our updated terms of service, privacy policy and cookie policy, and that your continued use of the website is subject to these policies.

Not the answer you're looking for? Browse other questions tagged or ask your own question.