I recently upgraded my system to GNOME 3. In previous versions of GNOME, the key combination Ctrl+Alt+D would hide all open windows and show the Desktop. This shortcut was eliminated from GNOME 3 along with the concept of a Desktop. The Desktop metaphor does, however, exist in GNOME 3 "fallback mode" (which I am using).

I would like to reinstate the Ctrl+Alt+D keyboard shortcut. I know at least two ways of creating key combinations in GNOME. One is through System Settings > Keyboard > Shortcuts, and the other is through gconf-editor > apps > metacity. From either of these environments, I can pair a command with the key combination Ctrl+Alt+D. The problem is that I don't know what command will trigger a "Show Desktop" event. Could someone enlighten me?


System Settings > Keyboard > Shortcuts > Navigation > Hide all normal windows

Click the second field which says Disabled and type in a key combination of choice (e.g., Ctrl+Alt+D).

System restart may be required for changes to take effect.


Are you using gnome3? If yes, you can go to the system settings -> keyboard -> shortcuts (if i'm not mistaken). Under one of the categories on the left, you should be able to set your own shortcut.

  • 1
    I recently upgraded to gnome3 but am now using fallback mode. Do you know what command will 'show desktop'? Another place I could do this is gconf-editor, but again I don't know what command to give. Thanks. – user001 Feb 1 '12 at 15:20

I'm relatively new at answering q's and unsure if this would provide any help but did you try Windows Key+D. Here's the URL that I found pretty helpful: http://www.raizlabs.com/blog/29/keyboard-shortcut-dictionary-and-glossary-ctrl-shift-alt-f1

  • Thank you very much. I think that list is intended for Windows users. Probably I should have been more clear that I'm on a linux box. – user001 Feb 1 '12 at 5:51
  • Super + D is what does I have it set to in openbox. You should add that you're using gnome3 to your question. – Rob Feb 2 '12 at 15:16

Ctrl + Alt + M... is what I have to "hide all normal windows"... I am using Fallback mode in fedora 17, because I started to experience some flakiness with normal Gnome 3... which I like, btw, but I would have dialog boxes pop up all black and stuff... can't work with that.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.