I have a computer on my network at home called "shuttle" running Win XP Pro. I can connect to this machine's file shares by visiting \\shuttle and it works fine.

However, the machine also has a web server and SQL Server installed. I'm unable to type http://shuttle/ into the web browser. If I ping shuttle I get a response from an external IP address that's not even mine! The response also mentions shuttle.WAG320N, but I don't know what that's referring to, it's the name of the router!

I can connect fine via IP address to the web server and SQL, so there's no connectivity problems. It seems to be DNS related, but Windows boxes should broadcast their computer names shouldn't they? I don't think it's an issue as the computer name works for accessing file shares just fine.

I recently got a new router, the Linksys WAG320N, and it worked ok before this so I'm pretty sure it's something to do with its setup. I'm just not sure what else I can check!

Thank you for your time.


Still having this problem and can't find an answer. Used to be able to access RDP, MySQL, VNC and HTTP using the machine name before this router - can anyone think of anything else I can try? :) Many thanks for your help.

Another update

If I do ping -a it says Pinging SHUTTLE, but if I do ping SHUTTLE it says Pinging SHUTTLE.WAG320 ( WAG320 is the name of the router - where's it getting that IP address from?!

  • 1
    Can you get to the web browser using the internal ip address of the machine. I'm wondering if when you type shuttle it's looking for that domain on the www instead of your local domain. – Joe Taylor Feb 1 '12 at 12:59
  • Yes, the browser will connect to the web server if I type the IP address. – greg84 Feb 2 '12 at 0:24

Finally sorted it out after weeks of frustration! Thought I'd stick the answer here in case anyone else has a Linksys WAG320N router and doesn't notice the issue in the default setup.

On the basic setup page there's an option for a "host name", which can be assigned to the router. The default value for this is WAG320N. This then gets 'broadcast' as the connection-specific DNS suffix. Removing this and leaving it blank solved the problem for any machine that was disconnected and reconnected to the router. I could finally type http://shuttle/ to get to my web server again - hooray! :)

Hope this helps someone...

enter image description here

  • Oh my god, my hero. – Robert P Jan 2 '13 at 3:27

When you enter http://shuttle/ in your browser, it searches for a domain of that name or does a google search depending on the browser, it Does not look for the local computer as it doesn't know that it should do that. You need to tell your computer that it should look for the local IP, say when you try to access http://shuttle/. To do that, open your hosts file of your computer you can find at C:\Windows\System32\drivers\etc\hosts, open it in any text editor, add this certain line -       shuttle

And restart your PC.

No, you cannot automatically connect to any PC on your LAN, from a web browser, with their machine name. Browsers will always try to look at the hosts file for any IP record like this to resolve a random address. So, you must add such record for each of the PCs on lan if you want to access them with their machine name instead of IP.

  • Hmm. Why did it work with my old router? Also this doesn't explain why I can't connect to it using SQL management studio, I enter "shuttle" as the computer name and it won't connect. It used to, I still have the credentials saved from when it did before! It works with the IP directly. Also, VNC and RDP don't work using the computer name either, but they do with the IP and they used to with the computer name. – greg84 Feb 2 '12 at 0:28
  • Which model was the old router? I'm not sure if any router has inbuilt feature of resolving machine names. – Bibhas Feb 2 '12 at 16:30
  • The old router was a Netgear DG834G v3. I've sold it on eBay now so can't reconnect it. But I've still got the history in my browser of visiting http://shuttle/ so it definitely worked and I'm not going crazy! – greg84 Feb 3 '12 at 0:19

There are a couple various name resolution protocols in use by Windows by default, including NetBIOS / WINS. This is not used by web browsers but is used internally by Windows. That would explain why you can hit \shuttle but not via a web page.

  • But what about SQL, VNC, RDP and MySQL? All services that with the old router used to work but now only work by IP address alone, not machine name :( – greg84 Feb 2 '12 at 0:28

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.