I am at work and having problems opening an excel file. I continue to get the error:

Excel cannot open the file XXX.xlsx" because the file format or file extension is not valid. Verify that the file has not been corrupted and that the file extension matches the format of the file.

After many searches I noticed that many have had this same problem. I am on a work computer that is connected to a server. I am unable to get onto the server computer and I'm not sure of our network set-up. This information cannot be revealed to me.

This is (one of) my conundrum: I cannot change the file extension. I managed to move it into a Zip folder, but that has not helped. I attempted to upload the file to my Google account, hoping the Google Gods will magically fix it, no avail. I cannot download a program to fix the corruption as I am not authorized to download anything.

I am almost positive that we are running on Windows XP, I know our Microsoft Office is version 2010.

Any help would be greatly appreciated!

  • "I cannot change the file extension." Why not? You're able to move it into a zip folder and upload the file, it would seem that you should be able to also change the extension (at least on a copy of the file). – Conrad Frix Feb 1 '12 at 17:54

I suspect, the file is not an excel file. This can be some other extension file, which has been changed to .xlsx format.


This is bit difficult to say, what is the actual file format?

But below is sample test i have run on my machine.


I have my PDF file, just I have changed extension to .xlsx.

Now I tried to open the file that assuming it is an excel file then I will get the same error.

So just try your file by changing extension to .pdf.

enter image description here

  • Please explain how Molly can check whether this is the case. – Daniel Beck Feb 1 '12 at 17:28
  • @DanielBeck: I have updated the answer with more details – Siva Charan Feb 1 '12 at 17:41
  • I would agree with that if he didn't do all of his work in Excel. I attempted to open it with Notepad and Word. No avail. My other issue is I am unable to change the file extension. – Molly Feb 1 '12 at 17:42
  • @molly what happened when you tried to open your file in notepad? if I am not mistaken notepad still SHOULD be able to open it...but it will be garbly goop. but it you get the same message...I do believe somthing is wonky with the file itself – mjrider Feb 1 '12 at 17:45
  • 1
    @SivaCharan Office Open XML formats are file collections bundled in a zip file. So the proper solution is to rename to .zip and see whether it can be extracted. – Daniel Beck Feb 1 '12 at 17:46

See if you have the Compatibility Pack for the 2007 Office System installed on the troubled machines. If you are running Office 2010, you no longer need this and I believe it causes this problem in SharePoint 2010.


have you tried opening this file on a different machine / os? currently cant tell if it is your machine or a issue with the file itself. first step would be to figure out if your FILE is valid. I dont know an easy way to confirm it is valed other than opening it.

first thing that can help a lot with trouble shooting issues is to visit http://supportdetails.com/ and then you can tell us a few more details.

next thing I would do is to download Libre office (which is a fork of openoffice but ... more open (long story)) then I would try and open your file with there version of excel to see if you can open it there.

  • I have attempted it on three machines, including mine. I do not have access to another machine not on this server. I do not have the ability to download anything. It's a paranoid rule, not set by me. – Molly Feb 1 '12 at 17:44
  • alright. that MAY make things a bit trickyer. – mjrider Feb 1 '12 at 17:45
  • uhhhh...do you have backups you can restore a working copy from? – mjrider Feb 1 '12 at 17:46

I would like to share my experience. Every time I update my Microsoft Office 2010 version my Excel file fails to open. I would get the same pop up as pictured above by Siva Charan: Excel cannot open...etc. This is how I solved my problem and I hope it'll solve yours too.

Right click on Microsoft Excel. Click on properties. Click on compatibility tab. Check mark the the box with "Run this program in compatibility mode for. Then click on the arrow for the drop menu and click on your Windows version (my windows version is 7). Then check mark the box under Privilege Level: Run this program as an administrator. Click ok.

Now try opening your Excel file again and it should open.


I've had success sometimes with this by going into the DOS command prompt and renaming the file there. Works if it is truly an Excel 2010 file.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.