I just bought a Canon MF3010 laser printer/scanner. The printer's great, but I can't get it to scan using the MF Toolbox software (which is the only way to scan to pdf format, I believe).

It will scan in Picasa and in the regular windows scanner program, but the buttons in MF Toolbox don't do anything.

Specifically: If I click the "Mail", "OCR", "Save", "PDF", "Color Scan", "B&W Scan", "Custom1", or "Custom2" buttons, the button flashes for a second, but nothing happens.

If I click the "Settings..." button, I do get a popup that asks me to select the scanner. Canon MF3010 is the only thing in the list. I then click OK, and the MF Toolbox window again flashes for a second, but nothing else happens.

Any suggestions? Thank you!

  • 2
    What OS are you using? Is the Canon software version for that specific OS? – Dave M Feb 2 '12 at 1:20
  • 1
    Go to the canon site and download the latest toolbox software for your specific OS and bit version, uninstall the old one and install the new one....usa.canon.com/cusa/support – Moab Feb 2 '12 at 2:40
  • I'm using Windows XP, and yes, this is the software that you download at usa.canon.com/cusa/consumer/products/printers_multifunction/… when you select XP as your OS. – Jer Feb 2 '12 at 13:19
  • And actually I never used the one that came on the CD, because my CD drive wasn't working - I started with the latest one from canon site. – Jer Feb 2 '12 at 13:20

Had same problem, the buttons in MF Toolbox just stopped working. Uninstalling/reinstalling print drivers and toolbox didn't help, to fix it I had to manually add the Twain driver directory (c:\Windows\twain_32\MF4100\ for my Canon MF4100) to system path.

  • I forgot I even asked this. I had fixed it a long time ago, but what you suggested sounds very familiar - I'm pretty sure that's what I had to do. – Jer Nov 25 '13 at 14:42

Well, this doesn't fix it, but I've loved the MF Toolbox software since I've had the Canon scanner for the past four years, but for some unknown reason it stopped responding to the buttons as the original poster said. When you press "Settings" it says it sees the 4100 scanner correctly, but not the WIA driver, just the regular Canon MF4100.

I wasn't able to get the buttons to work but I can get the scanner to work. Put your docs in the document feeder, press SCAN on the scanner, then press START. It will start the Toolbox software correctly and you can do everything you need. It will continue to work as long as you don't close the Toolbox software. If you do, then you need to do this procedure again.

MF Toolbox is the only software that can handle big scanning jobs with a lot of pages. My MF 4100 works fine scanning from IrfanView or MSPaint but it won't do mutliple pages. When I run those scanners it works with the WIA scan mode.

The MF Toolbox does not "see" the WIA scanner.

BTW, I also tried the above fix of adding the path to the system path but that didn't work.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.