10

I'm copying quite a bit of text from Word into a text-based application, line by line. The word text is structured like this:

  1. Topic

    a. Item A

    b. Item B

When I highlight Item A, copy, and then paste into the text-based application, I get a. Item A rather than just Item A as desired.

How can I prevent Word from including the bullet letter when copying?

  • This behavior is the same in Outlook. – Elaskanator Jan 21 at 15:27
4

The only way I can see that you could avoid include the numbering is to turn it off prior to copy.

Word Numbers icon

Word will generally include as much information as it can in the copy, and it is up to the recieving application to extract what information it can use.

  • 1
    But then I lose valuable formatting... I could solve the problem I guess by saving as a text file, but the formatting is very useful while moving data from Word to the external app. – Eric J. Feb 2 '12 at 3:22
  • Disabling numbering should only remove the numbering formatting - am I missing something? – Paul Feb 2 '12 at 3:26
  • 1
    Also... interestingly... if I copy the text 1. Topic, I don't get the numbering, just Topic. – Eric J. Feb 2 '12 at 3:27
  • What is the recieving app? – Paul Feb 2 '12 at 3:27
  • 2
    My suggestion was only to disable numbering for the copy action, then put it back (ctrl-z). Not to get rid of it entirely. – Paul Feb 2 '12 at 5:46
11

Hold the Alt button and select the text, Ctrl+C to copy, Ctrl+V to paste it anywhere excluding the bullet letter.

  • 1
    This works for text that's on a single line, but not multiline. – James Feb 14 '18 at 17:48
  • As of March 2019, this totally works for single or multi-lines/multi-bullets, therefore this should be deemed the correct answer imo. – Studocwho Mar 13 at 23:22
2

Old post but had to do it today.

  1. Highlight the bullet text by dragging from first letter in word to the end last word only.
  2. If you go pass the last letter you will see a half empty space highlighted.
  3. Drag the cursor back to end of the last letter if you also hightlight the half space.
  4. Copy the line (unfortunately, only one line at a time).

That half empty space (end of each bullet) is the hidden formatting of the bullet. If you copy (double, triple clicking by default), you also copy the bullet or list number.

  • This only works if you stay within an application in Office (i.e. behaves the same in Outlook). Moving to another app (e.g. Notepad, or the Windows Explorer address bar, or even pasting in a command line) includes the bullet point no matter what. Really frustrating when you're trying to grab network paths from stuff. – Elaskanator Jan 21 at 15:26
1

ALT select somewhat works. But it is a block select.

I came up with much simpler way:
copy the whole text from Word into your favorite Text editor (Notepad2-Mod, Notepad++).
Now select and  copy only text without any pesky extra chars.
0

At least in Microsoft Word 2010, I can select the entire bullet text except the first character, which I temporarily store in my head, and copy the selection.

Then, when I want to paste the text, I simply type the character temporarily stored in my head followed by a clipboard paste. The clipboard will not contain any bullet.

-2

Instead of selecting the complete text in the bullet line, try carefully selecting just the words. Do not extend the cursor beyond the text and it should just copy the words without the bullet. Little painful, but works.

  • 1
    This is almost identical to another answer already posted. Can you edit your answer to expand upon what is different with your technique? – Burgi May 2 '16 at 2:57
-3

File -> Word Options -> Advanced

Scroll down to the "Cut, copy, and paste" section

Turn off "Keep bullets and numbers when pasting text with Keep Text Only option

  • 1
    This only applies to pasting within Word documents. If you copy and paste to another application this will not work. – J.Steve Jan 4 '16 at 16:24

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.