2

I set up a dual-boot with Windows 7 and Ubuntu Server 11.10. Everything works fine until I boot into Windows. After booting into Windows, the machine reboots when I select Linux from the grub menu. However, Windows continues to operate normally.

The system has two 500GB SATA hard disks and a 42GB IDE hard disk. The first SATA HDD contains Windows, the second SATA HDD contains my personal files (NTFS), and the IDE HDD contains Linux.

I have reinstalled Linux several times and it continues to have the same problem. During setup, I selected Use the entire disk and setup LVM and installed grub to the MBR of the IDE disk. I had another system previously that worked well with this configuration.

Could it be that Windows is causing problems with grub, or is it that I have mixed SATA and IDE HDDs, or something else?

  • Do you have ubuntu automatically mount the windows partitions? If you put windows to sleep instead of shutting it down, it can sometimes cause issues (though it's never refused to boot for me because of that) – Rob Feb 2 '12 at 15:10
  • It was shut down completely – ctype.h Feb 2 '12 at 15:16
1

A general procedure to dual boot (since you mentioned MBR, I've written for that here):

1) Turn off fast startup in Windows (8 and above)

2) Install Linux to two ext4 partition (and maybe one swap)

3) Install GRUB to one HDD

4) Make the Linux MBR hard disk your primary boot drive (The one with GRUB)

In case you have done this, especially setting the GRUB HDD as primary boot in BIOS, and it still doesn't work, there are two possibilites:

1) You didn't install GRUB properly. This happens often. Try letting an automated installer (like Ubuntu) to setup everything for you.

2) Something about mixing SATA and IDE (though this shouldn't really happen)

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.