I was advised to use the following command, from the Windows command line, in order to get my softphone to dial a number:

@="\"C:\\Program Files\\qutecom\\qutecom.exe\" \"-c\" \"call\\%1\""

However, when I use that command, I get an error saying "The filename, directory name, or volume label syntax is incorrect. I am sure that the path is correct.

I was also told to use the command below:

"c:\program files\qutecom\qutecom.exe" -c call\%1

When I use this command, the softphone opens, but doesn't dial.

The documented command for the softphone is qutecom -c call\123456. Can someone help me get the syntax right? I am unfamiliar with editing the registry. Any help would be greatly appreciated.


The syntax you are using is correct and works for me:

Qutecom command line dialing

The version installed is 2.2 on a Windows 7 x64 machine. Trying a re-install might help, but there is a unresolved bug where dialing from the command line doesn't seem to work. Perhaps try a different SIP client, or a different machine for testing.

  • I got it working for a few calls by adding a few apostrophes, but then it stopped. Now, it seems like the browser is passing "tell:" along with the number. I tried tel:1111111111 in Firefox and Explorer and each has the same problem. The error message it gives is user/number not found tel:+1111111111. If I issue the command from the command line, QuteCom dials the number just fine. Thanks for your help. It looks like it will be another day of fiddling for me. – Arthur Feb 3 '12 at 4:11
  • If it is passing the URI (tel:) through with the number, then I would consider using a batch file as the target for the registry command, and have that batch file strip off the tel: and pass the number to qutecom (this also means that if you change SIP clients, you just edit the batch file, rather than the registry) – Paul Feb 3 '12 at 4:34
  • It sems to be the % that is causing the problem. If I take the %1 off and replace it with a +, it passes 001, without the tell:+. I've tried a bunch of different combinations, but there doesn't seem to be a way to di it without the %. I don't know how to make a batch file. I guess I'll try to figure out. Thanks for the help. – Arthur Feb 3 '12 at 5:33

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.