I bought a new HP dv6 laptop with Windows 7 installed, a 750GB hard drive and 8GB RAM.

I wanted to dual boot and install Ubuntu 11.10. Following a known procedure I shrunk my partition and created 30GB (unallocated space). I inserted a bootable USB key but the GUI installer showed the following message:

Ubuntu detected that there are multiple OS are installed on your device.

There were two options:

  1. Erase the entire disk and install Ubuntu
  2. Do something else

When I chose the second option, it did not detect the unallocated space that I had created. It also showed me this:

SDA1 Windows7 (loader)
SDA2 Windows7 (loader)

I don't know how it's detecting multiple loaders or why it's not finding unallocated space for installation.

I also tried to fix the problem by unallocating the space using GParted but nothing happened. I think the space I unallocated using Gparted is now not detected by Windows 7.

I also tried Wubi which gave an unknown error while installing.

How can I fix this?

  • Possible Duplicate You will have to perform a HP Recovery, then read this...superuser.com/questions/359414/…
    – Moab
    Feb 3, 2012 at 4:25
  • Windows 7 requires a 100MB reserved boot partition. Could this be what you are seeing? You did not provide the sizes.
    – iglvzx
    Feb 3, 2012 at 4:45


You must log in to answer this question.

Browse other questions tagged .