I read some tutorials, but for some reason, I can't download the file:

  1. On the source PC (ie. the one that has the file I want to share), I launched uTorrent, chose File > Create New Torrent, and created the .torrent file.

FWIW, I later tried using OpenBitTorrent as the single tracker instead, but it made no difference.

For some reason, the file is displayed in the Downloading section, with nothing happening ("Downloading 0.0%"): enter image description here

Why am I required to download a file that I already have, and why is nothing happening?

  1. Uploaded the .torrent file to a web server

  2. On a second host, launched uTorrent, and pasted the URL from the web server: It just says "Downloading 0.0%", with no action.

Looks like I'm missing something. Does someone have an idea what it could be?

Thank you.

  • the torrents need to be hosted at piratebay and meganova where you have the trackers listed, if you plan on hosting your own torrents you will have to set up a tracker server, otherwise upload them to one of a thousand torrent hosting sites like piratebay. – Moab Feb 3 '12 at 21:12
  • Doesn't uTorrent take care of connecting to the trackers and uploading stuff there? The tutorials I read didn't specify I had to do anything more than this. – OverTheRainbow Feb 3 '12 at 22:24
  • No, you have to go to the site and upload the torrent manually. Most require registration/membership before you can upload a torrent. – Moab Feb 3 '12 at 22:31
  • I added two trackers when creating the Torrent file, but I get the same result: uTorrent is waiting to download :-/ udp://tracker.publicbt.com:80/announce udp://tracker.openbittorrent.com:80/announce – OverTheRainbow Feb 3 '12 at 22:38
  • "PublicBitTorrent is a bittorrent tracker free for anyone to use. You don't need to register, upload or index a torrent anywhere, all you have to do is to include the PublicBitTorrent tracker URL in your torrent." – OverTheRainbow Feb 3 '12 at 22:39

Most likely, the problem is that both machines are behind NAT. The torrent protocol doesn't know they're both behind the same NAT and doesn't specially handle that case. It assumes a system behind NAT can't initiate a connection to any other system behind NAT. So if both ends are behind NAT, a connection is not possible.

If you want to set up a torrent seed behind NAT, you really need to set up port forwarding.

| improve this answer | |
  • Sorry, forgot to say I mapped a port on the NAT for the incoming connection needed by uTorrent. – OverTheRainbow Feb 3 '12 at 22:24
  • To which machine? (And if your router doesn't support hairpin NAT, that would explain why you weren't able to download it. The mapping only works for incoming connections.) – David Schwartz Feb 3 '12 at 22:58
  • I made sure PC #2 was connected to another network, although it doesn't have a port mapped (but as I understand it, it doesn't prevent downloading, only it's slower) – OverTheRainbow Feb 4 '12 at 8:56
  • It finally worked with that tracker: udp://tracker.openbittorrent.com:80/announce, although the client had to wait about 10mn for downloading to start. – OverTheRainbow Feb 4 '12 at 17:08

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.