I was having some issues with this so I uninstalled everything associated with VS 2010 and .NET Framework 4 and reinstalled everything, well except Service Pack 1, which will not install. Without it installed I get this whenever I try to open Visual Studio 2010:

enter image description here

And this is the error I get when I try to install Service Pack 1

enter image description here

Can someone please help me with thnis issue?

  • Any chance to get a look at that log file mentioned in the dialog in that screenshot? – Der Hochstapler Feb 4 '12 at 1:19
  • Working on it now, will post it once the install fails – PsychoCoder Feb 4 '12 at 1:40
  • This is what the log file shows: psychocoder.net/logfile.txt – PsychoCoder Feb 4 '12 at 1:54
  • Have you checked the answer given in this question yet? I think the error code 0x80070643 is the important bit of information. – Der Hochstapler Feb 4 '12 at 1:56
  • Yes I checked it and it didn't offer any help – PsychoCoder Feb 4 '12 at 2:39

According to the log file it is blowing attempting to patch the Team Foundation Server Object Model components.

from file: Patch (L:\VS10sp1-KB983509.msp;L:\VS10sp1-KB2413561.msp;L:\VC10sp1-KB983509-x86.msp;L:\VC10sp1-KB983509-x64.msp;L:\VC10sp1-KB983509-IA64.msp;L:\VS10sp1-KB983509-Pro.msp) Install failed on product (Microsoft Team Foundation Server 2010 Object Model - ENU).

If you are not using TFS, then you should be able to uninstall these from your computer via Add/Remove programs. They should show up as 'Microsoft Team Foundation Server 2010 Object Model -ENU'. Once you have these uninstalled, perhaps you can try re-applying the service pack and again post the log file if it fails.

If they are not in your Add/Remove programs perhaps they did not properly get uninstalled previously? You may need to use msizap to permanently remove any traces of them.

  • I did what you said and this time it made it 1/2 into the install before it started rollback. It was looking for ADONETEntityFrameworkTools_enu.msi and I directed to that file and it's still failing. – PsychoCoder Feb 4 '12 at 2:38
  • Please post the log again. It will help identify what the install failure is and what component is the problem. It seems like you have a really botched install of Visual Studio. – Art Feb 4 '12 at 4:03
  • My initial guess is that the 'Microsoft ADO.NET Entity Framework Tools' are the problem component. When you un-installed Visual Studio, did you also uninstall all of the other components it puts down, like the previously mentioned 'Microsoft ADO.NET Entity Framework Tools' and 'Microsoft Team Foundation Server 2010 Object Model -ENU' re-installed Visual Studio 2010? All of these get put down by the default install of Visual Studio. – Art Feb 4 '12 at 4:05
  • Yes sir, when I uninstall I make sure to uninstall everything associated with VS 2010. Right now my latest attempt to install SP1 is failing, once it's complete I'll post the log file again – PsychoCoder Feb 4 '12 at 5:38
  • Here's the latest log file from the failed installation psychocoder.net/logfile2.txt – PsychoCoder Feb 4 '12 at 5:43

Are you sure you got all the VS2010 products uninstalled? (For example, if you had express installed, then installed another version.) In my list of installed apps I see three different items with "Visual Studio 2010" listed as part of their names. I would try to uninstall all of them before re-installing and re-applying the service pack.

I don't suppose there was anything helpful in the log?

  • Nothing of use in the log. I uninstalled everything related to VS 2010 (never had Express installed) and .NET 4.0 and reinstalled, but nothing changes SP 1 just wont install – PsychoCoder Feb 4 '12 at 1:36

I tried everything that was suggested here, and I thank everyone who took the time to try and help me. I ended up formatting my drive and re-installing Windows and all works now.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.