2

I'm printing a PDF document using LPR on OS X, to a Canon MP190 printer. When printing the same document (Letter paper size) from the Preview app, the margins are correct.
When printing using LPR, the document is printed, but it is offset (it is 3/4" lower on the page). I have tried changing all possible options using lpoptions, but none of them affect scaling or offset. I made sure to set -o media=Letter instead of the a4 page size option. Some options actually get ignored completely (it still prints color when CNIJGrayScale is set to 1 or 2), but others are respected, such as Resolution=600x600dpi

  • 1
    Looks like I had missed one printer-specific option: -o PageSize=na-letter That fixed it. – stupakov Feb 4 '12 at 9:46
  • 3
    Once you can, please post your answer below by using the answer your question button, thanks! – slhck Feb 4 '12 at 9:48
0

You missed one printer-specific option: -o PageSize=na-letter.

0

In general, you can use the command lpoptions -l to show all the printer-specific options for your printer, and then pick the correct page size for your printer. In the case of my printer, the correct option was 8.5x11.

lp -o PageSize=8.5x11 -o media=Letter example.pdf

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.