Possible Duplicate:
How to solve the “Bootmgr is missing” problem on Windows 7 machine?

I've just bought a shiny SSD to add to my Dell Studio 1747 laptop. This has been installed as a second drive .

Since Dell don't ship their laptops with Windows 7 discs, a year ago when I bought the PC I used Norton Ghost 12 to create a recovery point. I have now restored that recovery point to the SSD and set it as Active.

When I restart the laptop, setting the SSD to primary boot drive, I get the message "BootMGR is missing". A google search and I find out that I am missing the 100MB "System Reserved" partition on the SSD to make it bootable.

How can I fix this? I've googled it and most solutions say to use the Windows 7 disc to re-intall or repair. I don't have this.

Alternatively I can use bcdboot.exe from the command line but how?

Current discs:

  • C: Windows 7 (old installation, currently boots from here)
  • F: SSD Drive with Windows 7 but missing BootMGR
  • H: Secondary drive with files/folders
  • 2
    Funny how people clone a disk, but don't select the disk, but rather the partition. I've seen this one too many times. – surfasb Feb 5 '12 at 2:13
  • Newer versions of Norton are to blame. Too noddy. The old dos version that did a forensic clone worked wonders – Dr. Andrew Burnett-Thompson Feb 5 '12 at 7:35

Solved by scrabbling around for a Win7 disc and just installing fresh. Once id done that I used the saved disc image to restore the C drive over the top. The result, I got my restored C and BootMGR.

A hassle but in the end the disc was needed.

| improve this answer | |

Not the answer you're looking for? Browse other questions tagged or ask your own question.